Help  Search  Portal
 Portal  Search
Hello There, Mystery Audiophile!  Register  Login

v0.1.5-pre-release-20160904


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
It's only been about a month since the last beta relase but it felt more like three. Been working on how to make it even easier for you guys to add/remove software players, so here it is.
[Image: cheer2.gif] This feature is protected behind the Snakeoil tab and only available to people who has activated their Snakeoil OS. Note that this is very much an experimental feature so please let me know if there are any issues.

CHANGELOG
Changes since v0.1.5-pre-release-20160801 
  • Ability to install/uninstall most software players from the Snakeoil tab now. Select Install to have the player show up in the Software tab or Not Installed to uninstall the player from the computer and not shown in the Software tab.
    [Image: Install_And_Uninstall.png]
  • Added support for RoonServer and JRiver MediaCenter 22 (RoonBridge and RoonServer is available only on 64 bits version)
  • Added new backend code for various features
  • Cleaned up and simplify some existing backend code
  • Don't return any remote web client when no software players are installed
  • Fixed up executable path detection for players (no more false positives for players that's uninstalled)
  • Allow one to update firmware/modules tagged as generic
DOWNLOAD

.fw   snakeoil-0.1.5-pre-release-20160904-i686.fw (Size: 18.59 MB / Downloads: 19)
.fw   snakeoil-0.1.5-pre-release-20160904-amd64.fw (Size: 19.06 MB / Downloads: 35)

VIDEO
Follow this video if you don't know how to upgrade firmware:


Follow The Music, Follow Snakeoil.
[-] The following 2 users Like agent_kith's post:
  • orgi70, Chanh
#2
Hi Agent_Kith,
Not sure if this is related to the new firmware but for some reason I cannot use the squeezeplayer anymore.
The error I get is:ERROR: Player [b]Squeezelite v1.8 failed to start.[/b]Last known error:
Code:
[b]avahi: Service 'snakeoil' successfully established. client: [0] opened from 127.0.0.1:37882 client: [1] opened from 127.0.0.1:37884 player: played "Populair/John_Scofield/[2015]_Past_Presents_(24bit_96kHz)/01_Slinky.wav"[/b]


It doesn't seem to recognize my DAC as a player. However MPD works fine.

Regards,
Leonard
#3
(07-Sep-2016, 08:12 PM) Leonard Wrote: Hi Agent_Kith,
Not sure if this is related to the new firmware but for some reason I cannot use the squeezeplayer anymore.
The error I get is:ERROR: Player [b]Squeezelite v1.8 failed to start.[/b]Last known error:
Code:
[b]avahi: Service 'snakeoil' successfully established. client: [0] opened from 127.0.0.1:37882 client: [1] opened from 127.0.0.1:37884 player: played "Populair/John_Scofield/[2015]_Past_Presents_(24bit_96kHz)/01_Slinky.wav"[/b]


It doesn't seem to recognize my DAC as a player. However MPD works fine.

Regards,
Leonard


Hmm that's an interesting one.. I'd check that later tonight and see if I can reproduce this.

Edit: Got a massive headache last night so didn't get to try this. Will be in touch on this..
Follow The Music, Follow Snakeoil.
#4
(07-Sep-2016, 08:12 PM) Leonard Wrote: Hi Agent_Kith,
Not sure if this is related to the new firmware but for some reason I cannot use the squeezeplayer anymore.
The error I get is:ERROR: Player [b]Squeezelite v1.8 failed to start.[/b]Last known error:
Code:
[b]avahi: Service 'snakeoil' successfully established. client: [0] opened from 127.0.0.1:37882 client: [1] opened from 127.0.0.1:37884 player: played "Populair/John_Scofield/[2015]_Past_Presents_(24bit_96kHz)/01_Slinky.wav"[/b]


It doesn't seem to recognize my DAC as a player. However MPD works fine.

Regards,
Leonard


@Leonard  I couldn't replicate this for some reason. Can you try and set the player to v1.8, and then try reboot the computer and see if squeezelite works?
Follow The Music, Follow Snakeoil.
 

Bookmarks
Possibly Related Threads...
 

Users browsing this thread: 1 Guest(s)