Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hoo to Install/Enable encoder: vorbis
#1
Question 
Hi All~~

How in install/enable encoder: vorbis?? When I change the MPD configure file to enable HTTP Stream, it will output an error about the encoder now found

Error message
 
Code:
**** MPD (0.23.5)

server_socket: bind to '0.0.0.0:6600' failed (continuing anyway, because binding to '[::]:6600' succeeded): Failed to bind socket: Address already in use
exception: Failed to configure output in line 359; No such encoder: vorbis

Setting added in mpd.conf.template
 
Code:
audio_output {
type            "httpd"
name            "My HTTP Stream"
encoder         "vorbis"                # optional, vorbis or lame
port            "8000"
format          "44100:16:1"
}

Thanks Thanks
Reply
#2
(18-Sep-2022, 04:47 PM)mola Wrote: Hi All~~

How in install/enable encoder: vorbis?? When I change the MPD configure file to enable HTTP Stream, it will output an error about the encoder now found

Error message
 
Code:
**** MPD (0.23.5)

server_socket: bind to '0.0.0.0:6600' failed (continuing anyway, because binding to '[::]:6600' succeeded): Failed to bind socket: Address already in use
exception: Failed to configure output in line 359; No such encoder: vorbis

Setting added in mpd.conf.template
 
Code:
audio_output {
type            "httpd"
name            "My HTTP Stream"
encoder         "vorbis"                # optional, vorbis or lame
port            "8000"
format          "44100:16:1"
}

Thanks Thanks
Take out vorbis and try again? Does that work? Or do you specifically want libVorbis codec?
Snakeoil Operating System - Music, your way!
Reply
#3
Not specifically want libVorbis codec. I just want stream to mobile and listen at outside with same playlist

It does not work when remove vorbis. Follwing is the output when change from encoder "vorbis" to encoder ""
 
Code:
**** MPD (0.23.5)

server_socket: bind to '0.0.0.0:6600' failed (continuing anyway, because binding to '[::]:6600' succeeded): Failed to bind socket: Address already in use
exception: Failed to configure output in line 359; No such encoder:

The result when change encoder "vorbis" to encoder "lame"
 
Code:
**** MPD (0.23.5)

server_socket: bind to '0.0.0.0:6600' failed (continuing anyway, because binding to '[::]:6600' succeeded): Failed to bind socket: Address already in use
exception: Failed to configure output in line 359; No such encoder: lame

Seems haven't include encoder in MPD Think
Reply
#4
(20-Sep-2022, 11:24 AM)mola Wrote: Not specifically want libVorbis codec. I just want stream to mobile and listen at outside with same playlist

It does not work when remove vorbis. Follwing is the output when change from encoder "vorbis" to encoder ""
 
Code:
**** MPD (0.23.5)

server_socket: bind to '0.0.0.0:6600' failed (continuing anyway, because binding to '[::]:6600' succeeded): Failed to bind socket: Address already in use
exception: Failed to configure output in line 359; No such encoder:

The result when change encoder "vorbis" to encoder "lame"
 
Code:
**** MPD (0.23.5)

server_socket: bind to '0.0.0.0:6600' failed (continuing anyway, because binding to '[::]:6600' succeeded): Failed to bind socket: Address already in use
exception: Failed to configure output in line 359; No such encoder: lame

Seems haven't include encoder in MPD Think
Yes, they aren't included. Try flac or wave. These are the only two encoders that's enabled.
Snakeoil Operating System - Music, your way!
Reply
#5
Got it. Thanks agent kith Thanks
Reply


Bookmarks

Possibly Related Threads…
Thread Author Replies Views Last Post
  Pi4 fresh install no upmpdcli mkysimes 0 3 3 hours ago
Last Post: mkysimes
Thumbs Down Where (folder) should I install a new version of mpd? pathetic 3 64 26-Jan-2022, 08:19 AM
Last Post: agent_kith
  [SOLVEDupmpdcli not working on fresh install of 20.04/1.2.0 Snoopy8 5 360 12-Aug-2021, 06:49 AM
Last Post: agent_kith
  Unable to uninstall MinimServer 0.8 to install Minimserver 2 bobzy 10 542 04-Jun-2021, 08:10 AM
Last Post: bobzy
  mympd not working, fresh install 20.04/1.2.0 Snoopy8 1 305 15-May-2021, 08:06 AM
Last Post: agent_kith



Users browsing this thread: 1 Guest(s)
[-]
Our Sponsors

[-]
Welcome
You have to register before you can post on our site.

Username/Email:


Password:





[-]
Latest Threads
Pi4 fresh install no upmpdcli
Last Post: mkysimes
Today 07:34 PM
» Replies: 0
» Views: 3
Horror Dashboard
Last Post: Snoopy8
Today 08:25 AM
» Replies: 14
» Views: 159
error opening volume TEAC dac
Last Post: agent_kith
Today 07:15 AM
» Replies: 1
» Views: 14
Nas to library
Last Post: agent_kith
Today 07:09 AM
» Replies: 3
» Views: 18
Allo Boss Dac i2s working...
Last Post: criminalzen
Yesterday 06:27 AM
» Replies: 0
» Views: 8
Interesting discussion developing over a...
Last Post: mkysimes
Yesterday 02:05 AM
» Replies: 1
» Views: 33
Snakeoil Installer- 1.2.6 (Gear Isolatio...
Last Post: yellowriver
26-Sep-2022 02:56 PM
» Replies: 51
» Views: 1189
Snakeoil Firmware - 1.2.8 (Gear Isolatio...
Last Post: agent_kith
25-Sep-2022 03:35 PM
» Replies: 0
» Views: 71
"remote button" under mpd in music play...
Last Post: agent_kith
25-Sep-2022 08:04 AM
» Replies: 5
» Views: 44
Copy Paste function
Last Post: agent_kith
24-Sep-2022 10:15 AM
» Replies: 1
» Views: 18

[-]
SnakeoilOS Mission Statement

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.