Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

How To Use Another Audio Device In Spotify Client


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
Hi again... a full 12 hours into my linux career I have now indeed gotten the above to work and I can see spotify songs playing botn over VNC and in the spotify app on my phone

However, there is no actual sound coming through to the DAC (ESI gigaport HD+). The blue USB power LED is on but not the red I/O LED, suggesting the music signal doesn't go that way.

To be able to select Spotify Connect I have to enable 'music server' and when I do that the ALSA output configuration disappears?
'Audio State' shown USB audio and 'in use'.... but the actual sound is coming through the headphone put of the snakeoil computer.

I'm missing something...
 Reply
#2
(05-Feb-2020, 03:34 PM) OscarH Wrote: To be able to select Spotify Connect I have to enable 'music server' and when I do that the ALSA output configuration disappears?
'Audio State' shown USB audio and 'in use'.... but the actual sound is coming through the headphone put of the snakeoil computer.

I'm missing something...

Very close now. From VNC, you have to select the USB as output device. Personally I would just disable the on board audio from the BIOS, making your USB the first device.
Snakeoil Operating System - Music, your way!
 Reply
#3
(05-Feb-2020, 03:55 PM) agent_kith Wrote:
(05-Feb-2020, 03:34 PM) OscarH Wrote: To be able to select Spotify Connect I have to enable 'music server' and when I do that the ALSA output configuration disappears?
'Audio State' shown USB audio and 'in use'.... but the actual sound is coming through the headphone put of the snakeoil computer.

I'm missing something...

Very close now. From VNC, you have to select the USB as output device. Personally I would just disable the on board audio from the BIOS, making your USB the first device.

As it's already painfully clear that I'm a complete novice I have essentially no pride left to loose in the 'stupid questions department'... I can't seem to find any such options either in the BIOS (Gigabyte motherboard, the 'Hakai' build') or via VNC. Is it a command I need to write or am I simply blind?

 Reply
#4
(05-Feb-2020, 04:48 PM) OscarH Wrote: As it's already painfully clear that I'm a complete novice I have essentially no pride left to loose in the 'stupid questions department'... I can't seem to find any such options either in the BIOS (Gigabyte motherboard, the 'Hakai' build') or via VNC. Is it a command I need to write or am I simply blind?

There're no such things as stupid questions, only stupid answers from me Tongue... Snakeoil is designed for the uninitiated, thus every feedback from you is more than welcome.

Do you have the exact model of the motherboard? Look for anything that says "Intel HD Audio", or "Azalia" (not sure if this is spelt correctly). and disable it.

That's option 1.

The other is to select the output device. I don't have Spotify Connect handy right now to get to the main GUI, but inside the Spotify Connect app there should be a setting for you to select another output device (your USB). If you can, send me a screenshot of the Spotify client so I can refresh my memory?
Snakeoil Operating System - Music, your way!
 Reply
#5
(05-Feb-2020, 05:07 PM) agent_kith Wrote:
(05-Feb-2020, 04:48 PM) OscarH Wrote: As it's already painfully clear that I'm a complete novice I have essentially no pride left to loose in the 'stupid questions department'... I can't seem to find any such options either in the BIOS (Gigabyte motherboard, the 'Hakai' build') or via VNC. Is it a command I need to write or am I simply blind?

There're no such things as stupid questions, only stupid answers from me Tongue... Snakeoil is designed for the uninitiated, thus every feedback from you is more than welcome.

Do you have the exact model of the motherboard? Look for anything that says "Intel HD Audio", or "Azalia" (not sure if this is spelt correctly). and disable it.

That's option 1.

The other is to select the output device. I don't have Spotify Connect handy right now to get to the main GUI, but inside the Spotify Connect app there should be a setting for you to select another output device (your USB). If you can, send me a screenshot of the Spotify client so I can refresh my memory?


Hi agent_kith,

It’s a 3050N-D2P motherboard.
I’ll have to have another look though the BIOS, but haven’t found any such terms yet.

Spotify doesn’t have output settings, it’s happy playing on any machine and doesn’t care where that machine sends the sound; usb, headphones, etc. At least on the windows pc’s I have the output selection is always done outside of Spotify.

I’m thinking it must be somewhere in the snakeoil computer.

REALLY appreciate your assistance and enthusiasm!
 Reply
#6
Splitting your issue to it's own thread as it deserves it's own section.
(05-Feb-2020, 05:20 PM) OscarH Wrote: It’s a 3050N-D2P motherboard.
I’ll have to have another look though the BIOS, but haven’t found any such terms yet.

I just checked the manual of your motherboard - I can't find the option to disable the on board audio either! First time for everything, never owned a m/b where I can't disable the audio card before.

Assuming your USB is the second audio device, can you try and upload this firmware module, then reboot the computer (or restart Spotify) and see if that fixes it? Refer to this section on how to upgrade the file to your Snakeoil PC.

Attached Files


.fw   use_alsa_1_as_default-1_0_0-generic.fw (Size: 496 bytes / Downloads: 1)

Snakeoil Operating System - Music, your way!
 Reply
#7
(05-Feb-2020, 05:52 PM) agent_kith Wrote: Splitting your issue to it's own thread as it deserves it's own section.
(05-Feb-2020, 05:20 PM) OscarH Wrote: It’s a 3050N-D2P motherboard.
I’ll have to have another look though the BIOS, but haven’t found any such terms yet.

I just checked the manual of your motherboard - I can't find the option to disable the on board audio either! First time for everything, never owned a m/b where I can't disable the audio card before.

Assuming your USB is the second audio device, can you try and upload this firmware module, then reboot the computer (or restart Spotify) and see if that fixes it? Refer to this section on how to upgrade the file to your Snakeoil PC.


Hello, just got home and tried that firmware. No change unfortunately.

It’s rather mysterious, I know of other users with gigabyte motherboards.

My NAS isn’t ready yet so I can’t try whether the other players have the same issue.

(06-Feb-2020, 12:30 AM) OscarH Wrote:
(05-Feb-2020, 05:52 PM) agent_kith Wrote: Splitting your issue to it's own thread as it deserves it's own section.
(05-Feb-2020, 05:20 PM) OscarH Wrote: It’s a 3050N-D2P motherboard.
I’ll have to have another look though the BIOS, but haven’t found any such terms yet.

I just checked the manual of your motherboard - I can't find the option to disable the on board audio either! First time for everything, never owned a m/b where I can't disable the audio card before.

Assuming your USB is the second audio device, can you try and upload this firmware module, then reboot the computer (or restart Spotify) and see if that fixes it? Refer to this section on how to upgrade the file to your Snakeoil PC.


Hello, just got home and tried that firmware. No change unfortunately.

It’s rather mysterious, I know of other users with gigabyte motherboards.

My NAS isn’t ready yet so I can’t try whether the other players have the same issue.


Also, the DAC comes on straight away on another (windows) pc so the DAC/USB cable is ok.

I obviously used a USB port to install Snakeoil so that’s working too.
 Reply
#8
(06-Feb-2020, 12:30 AM) OscarH Wrote:
(05-Feb-2020, 05:52 PM) agent_kith Wrote: Splitting your issue to it's own thread as it deserves it's own section.
(05-Feb-2020, 05:20 PM) OscarH Wrote: It’s a 3050N-D2P motherboard.
I’ll have to have another look though the BIOS, but haven’t found any such terms yet.

I just checked the manual of your motherboard - I can't find the option to disable the on board audio either! First time for everything, never owned a m/b where I can't disable the audio card before.

Assuming your USB is the second audio device, can you try and upload this firmware module, then reboot the computer (or restart Spotify) and see if that fixes it? Refer to this section on how to upgrade the file to your Snakeoil PC.


Hello, just got home and tried that firmware. No change unfortunately.

It’s rather mysterious, I know of other users with gigabyte motherboards.

My NAS isn’t ready yet so I can’t try whether the other players have the same issue.

(06-Feb-2020, 12:30 AM) OscarH Wrote:
(05-Feb-2020, 05:52 PM) agent_kith Wrote: Splitting your issue to it's own thread as it deserves it's own section.
(05-Feb-2020, 05:20 PM) OscarH Wrote: It’s a 3050N-D2P motherboard.
I’ll have to have another look though the BIOS, but haven’t found any such terms yet.

I just checked the manual of your motherboard - I can't find the option to disable the on board audio either! First time for everything, never owned a m/b where I can't disable the audio card before.

Assuming your USB is the second audio device, can you try and upload this firmware module, then reboot the computer (or restart Spotify) and see if that fixes it? Refer to this section on how to upgrade the file to your Snakeoil PC.


Hello, just got home and tried that firmware. No change unfortunately.

It’s rather mysterious, I know of other users with gigabyte motherboards.

My NAS isn’t ready yet so I can’t try whether the other players have the same issue.


Also, the DAC comes on straight away on another (windows) pc so the DAC/USB cable is ok.

I obviously used a USB port to install Snakeoil so that’s working too.


I’ll continue talking to myself/further troubleshooting while Oz is asleep.

Saved some flac files locally and played them successfully via MPD. So the computer is fully capable of sending the audio to the USB port, however doesn’t manage to while in Spotify mode.
 Reply
#9
(06-Feb-2020, 04:00 AM) OscarH Wrote: I’ll continue talking to myself/further troubleshooting while Oz is asleep.

Saved some flac files locally and played them successfully via MPD. So the computer is fully capable of sending the audio to the USB port, however doesn’t manage to while in Spotify mode.

Strange, that worked for me. Did you restart your PC or Spotify Connect?

Yeah, the 'problem' is twofold:
  1. Spotify Connect dosn't appear to have an option to specify an output device
  2. I cannot find a way to disable your on board audio
That's more ways to skin a cat. Let's try to use software to disable your on board audio. This will require you to SSH into your computer and remove the fix from earlier. Here are the steps:
  1. Read this section on how to start a SSH session into your Snakeoil PC.
  2. Once you're in, run the following command:
    Code:
    sudo rm /etc/asound.conf

  3. Now go here and download the new kernel. You'll need the i686 version
  4. Reboot the PC
  5. Try and play some music again
  6. If the above still doesn't work, generate a diagnostics file (System menu) and send it to the email specified. That encrypted file contains your PC information (audio devices, etc) that will give me a better idea why things aren't working
Snakeoil Operating System - Music, your way!
 Reply
#10
(06-Feb-2020, 07:57 AM) agent_kith Wrote:
(06-Feb-2020, 04:00 AM) OscarH Wrote: I’ll continue talking to myself/further troubleshooting while Oz is asleep.

Saved some flac files locally and played them successfully via MPD. So the computer is fully capable of sending the audio to the USB port, however doesn’t manage to while in Spotify mode.

Strange, that worked for me. Did you restart your PC or Spotify Connect?

Yeah, the 'problem' is twofold:
  1. Spotify Connect dosn't appear to have an option to specify an output device
  2. I cannot find a way to disable your on board audio
That's more ways to skin a cat. Let's try to use software to disable your on board audio. This will require you to SSH into your computer and remove the fix from earlier. Here are the steps:
  1. Read this section on how to start a SSH session into your Snakeoil PC.
  2. Once you're in, run the following command:
    Code:
    sudo rm /etc/asound.conf

  3. Now go here and download the new kernel. You'll need the i686 version
  4. Reboot the PC
  5. Try and play some music again
  6. If the above still doesn't work, generate a diagnostics file (System menu) and send it to the email specified. That encrypted file contains your PC information (audio devices, etc) that will give me a better idea why things aren't working


No luck I’m afraid...

It seems as if all outputs except USB have now been successfully disabled for all players.

The MPD player and upnp plays just like before.

However Spotify now fails to play at all but instead for each song comes up with the error ‘song unavailable’. This error typically comes when a computer is offline, however this is not the case as other internet functions are there.

Have sent you the diagnostics file.
 Reply
 

Bookmarks
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Latest Threads
[-]
Advertising
[-]
Possibly Related Threads…
 

Users browsing this thread: 1 Guest(s)