Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
JRiver 27 seg faults in Gear Isolation
#1
I have been using Snakeoil 1.1 with JRiver 25 as music server since 2019 with great result, it plays great and no problems whatsoever.  Smile Thumbs Up
Now when version 1.2 has been released I decided to try it out, in Vmware, it's much easier to install with the new script on top on Ubuntu server.
However I can't get Jriver 27 to start, I also have some dependency problems during install but I sort them out:
Install:
 
PHP Code:
vmware@ubuntu20lts:~$ sudo dpkg -i MC27.0.84.deb
[sudopassword for vmware
Selecting previously unselected package mediacenter27.
(
Reading database ... 131523 files and directories currently installed.)
Preparing to unpack MC27.0.84.deb ...
Unpacking mediacenter27 (27.0.84) ...
dpkgdependency problems prevent configuration of mediacenter27:
 
mediacenter27 depends on libgtk-3-(>= 3.24); however:
  
Package libgtk-3-0 is not installed.
 
mediacenter27 depends on libpangox-1.0-(>= 0.0.2-5); however:
  
Package libpangox-1.0-0 is not installed.
 
mediacenter27 depends on libpangoxft-1.0-(>= 1.42); however:
  
Package libpangoxft-1.0-0 is not installed.
 
mediacenter27 depends on libnss3 (>= 2:3.42); however:
  
Package libnss3 is not installed.
 
mediacenter27 depends on libnspr4 (>= 2:4.20); however:
  
Package libnspr4 is not installed.
 
mediacenter27 depends on xdg-utilshowever:
  
Package xdg-utils is not installed.
 
mediacenter27 depends on libgbm1 (>= 18.3.6); however:
  
Package libgbm1 is not installed.
 
mediacenter27 depends on libva2 (>= 2.4.0); however:
  
Package libva2 is not installed.

dpkgerror processing package mediacenter27 (--install):
 
dependency problems leaving unconfigured
Processing triggers 
for mime-support (3.64ubuntu1) ...
Processing triggers for shared-mime-info (1.15-1) ...
Errors were encountered while processing:
 
mediacenter27 
I then run "apt --fix-broken install"
 
PHP Code:
vmware@ubuntu20lts:~$ sudo apt --fix-broken install
Reading package lists
... Done
Building dependency tree       
Reading state information
... Done
Correcting dependencies
... Done
The following additional packages will be installed
:
  
at-spi2-core i965-va-driver intel-media-va-driver libatk-bridge2.0-0 libatspi2.0-0 libcolord2
  libepoxy0 libfile
-basedir-perl libfile-desktopentry-perl libfile-mimeinfo-perl libgbm1
  libgtk
-3-0 libgtk-3-bin libgtk-3-common libigdgmm11 libio-stringy-perl libipc-system-simple-perl
  liblcms2
-2 libnet-dbus-perl libnspr4 libnss3 libpangox-1.0-0 libpangoxft-1.0-0 librest-0.7-0
  libsoup
-gnome2.4-1 libtie-ixhash-perl libva2 libwayland-cursor0 libwayland-egl1
  libwayland
-server0 libx11-protocol-perl libxkbcommon0 libxml-parser-perl libxml-twig-perl
  libxml
-xpathengine-perl mesa-va-drivers va-driver-all xdg-utils
Suggested packages
:
  
i965-va-driver-shaders colord gvfs liblcms2-utils libunicode-map8-perl libunicode-string-perl
  xml
-twig-tools
The following 
NEW packages will be installed:
  
at-spi2-core i965-va-driver intel-media-va-driver libatk-bridge2.0-0 libatspi2.0-0 libcolord2
  libepoxy0 libfile
-basedir-perl libfile-desktopentry-perl libfile-mimeinfo-perl libgbm1
  libgtk
-3-0 libgtk-3-bin libgtk-3-common libigdgmm11 libio-stringy-perl libipc-system-simple-perl
  liblcms2
-2 libnet-dbus-perl libnspr4 libnss3 libpangox-1.0-0 libpangoxft-1.0-0 librest-0.7-0
  libsoup
-gnome2.4-1 libtie-ixhash-perl libva2 libwayland-cursor0 libwayland-egl1
  libwayland
-server0 libx11-protocol-perl libxkbcommon0 libxml-parser-perl libxml-twig-perl
  libxml
-xpathengine-perl mesa-va-drivers va-driver-all xdg-utils
0 upgraded
38 newly installed0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 11.6 MB of archives.
After this operation68.3 MB of additional disk space will be used.
Do 
you want to continue? [Y/ny
Get
:1 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libatspi2.0-0 amd64 2.36.0-2 [64.2 kB]
Get:2 http://se.archive.ubuntu.com/ubuntu focal-updates/main amd64 libatk-bridge2.0-0 amd64 2.34.2-0ubuntu2~20.04.1 [58.2 kB]
Get:3 http://se.archive.ubuntu.com/ubuntu focal/main amd64 liblcms2-2 amd64 2.9-4 [140 kB]
Get:4 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libcolord2 amd64 1.4.4-2 [133 kB]
Get:5 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libepoxy0 amd64 1.5.4-1 [191 kB]
Get:6 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libsoup-gnome2.4-1 amd64 2.70.0-1 [6136 B]
Get:7 http://se.archive.ubuntu.com/ubuntu focal/main amd64 librest-0.7-0 amd64 0.8.1-1 [32.2 kB]
Get:8 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libwayland-cursor0 amd64 1.18.0-1 [10.3 kB]
Get:9 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libwayland-egl1 amd64 1.18.0-1 [5692 B]
Get:10 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libxkbcommon0 amd64 0.10.0-1 [98.4 kB]
Get:11 http://se.archive.ubuntu.com/ubuntu focal-updates/main amd64 libgtk-3-common all 3.24.20-0ubuntu1 [235 kB]
Get:12 http://se.archive.ubuntu.com/ubuntu focal-updates/main amd64 libgtk-3-0 amd64 3.24.20-0ubuntu1 [2620 kB]
Get:13 http://se.archive.ubuntu.com/ubuntu focal/universe amd64 libpangox-1.0-0 amd64 0.0.2-5ubuntu1 [41.9 kB]
Get:14 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libpangoxft-1.0-0 amd64 1.44.7-2ubuntu4 [18.0 kB]
Get:15 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libnspr4 amd64 2:4.25-1 [107 kB]
Get:16 http://se.archive.ubuntu.com/ubuntu focal-updates/main amd64 libnss3 amd64 2:3.49.1-1ubuntu1.5 [1256 kB]
Get:17 http://se.archive.ubuntu.com/ubuntu focal-updates/main amd64 xdg-utils all 1.1.3-2ubuntu1.20.04.2 [61.4 kB]
Get:18 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libwayland-server0 amd64 1.18.0-1 [31.6 kB]
Get:19 http://se.archive.ubuntu.com/ubuntu focal-updates/main amd64 libgbm1 amd64 20.2.6-0ubuntu0.20.04.1 [30.4 kB]
Get:20 http://se.archive.ubuntu.com/ubuntu focal/universe amd64 libva2 amd64 2.7.0-2 [53.5 kB]
Get:21 http://se.archive.ubuntu.com/ubuntu focal/main amd64 at-spi2-core amd64 2.36.0-2 [48.7 kB]
Get:22 http://se.archive.ubuntu.com/ubuntu focal/universe amd64 libigdgmm11 amd64 20.1.1+ds1-1 [111 kB]
Get:23 http://se.archive.ubuntu.com/ubuntu focal/universe amd64 intel-media-va-driver amd64 20.1.1+dfsg1-1 [1764 kB]
Get:24 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libipc-system-simple-perl all 1.26-1 [22.8 kB]
Get:25 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libfile-basedir-perl all 0.08-1 [16.9 kB]
Get:26 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libfile-desktopentry-perl all 0.22-1 [18.2 kB]
Get:27 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libfile-mimeinfo-perl all 0.29-1 [41.5 kB]
Get:28 http://se.archive.ubuntu.com/ubuntu focal-updates/main amd64 libgtk-3-bin amd64 3.24.20-0ubuntu1 [61.9 kB]
Get:29 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libio-stringy-perl all 2.111-3 [55.8 kB]
Get:30 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libxml-parser-perl amd64 2.46-1 [193 kB]
Get:31 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libxml-twig-perl all 1:3.50-2 [155 kB]
Get:32 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libnet-dbus-perl amd64 1.2.0-1 [177 kB]
Get:33 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libtie-ixhash-perl all 1.23-2 [11.2 kB]
Get:34 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libx11-protocol-perl all 0.56-7 [149 kB]
Get:35 http://se.archive.ubuntu.com/ubuntu focal/main amd64 libxml-xpathengine-perl all 0.14-1 [31.8 kB]
Get:36 http://se.archive.ubuntu.com/ubuntu focal-updates/universe amd64 mesa-va-drivers amd64 20.2.6-0ubuntu0.20.04.1 [2618 kB]
Get:37 http://se.archive.ubuntu.com/ubuntu focal/universe amd64 i965-va-driver amd64 2.4.0-0ubuntu1 [924 kB]
Get:38 http://se.archive.ubuntu.com/ubuntu focal/universe amd64 va-driver-all amd64 2.7.0-2 [4020 B]
Fetched 11.6 MB in 0s (27.8 MB/s)   
Extracting templates from packages100%
Selecting previously unselected package libatspi2.0-0:amd64.
(
Reading database ... 134177 files and directories currently installed.)
Preparing to unpack .../00-libatspi2.0-0_2.36.0-2_amd64.deb ...
Unpacking libatspi2.0-0:amd64 (2.36.0-2) ...
Selecting previously unselected package libatk-bridge2.0-0:amd64.
Preparing to unpack .../01-libatk-bridge2.0-0_2.34.2-0ubuntu2~20.04.1_amd64.deb ...
Unpacking libatk-bridge2.0-0:amd64 (2.34.2-0ubuntu2~20.04.1) ...
Selecting previously unselected package liblcms2-2:amd64.
Preparing to unpack .../02-liblcms2-2_2.9-4_amd64.deb ...
Unpacking liblcms2-2:amd64 (2.9-4) ...
Selecting previously unselected package libcolord2:amd64.
Preparing to unpack .../03-libcolord2_1.4.4-2_amd64.deb ...
Unpacking libcolord2:amd64 (1.4.4-2) ...
Selecting previously unselected package libepoxy0:amd64.
Preparing to unpack .../04-libepoxy0_1.5.4-1_amd64.deb ...
Unpacking libepoxy0:amd64 (1.5.4-1) ...
Selecting previously unselected package libsoup-gnome2.4-1:amd64.
Preparing to unpack .../05-libsoup-gnome2.4-1_2.70.0-1_amd64.deb ...
Unpacking libsoup-gnome2.4-1:amd64 (2.70.0-1) ...
Selecting previously unselected package librest-0.7-0:amd64.
Preparing to unpack .../06-librest-0.7-0_0.8.1-1_amd64.deb ...
Unpacking librest-0.7-0:amd64 (0.8.1-1) ...
Selecting previously unselected package libwayland-cursor0:amd64.
Preparing to unpack .../07-libwayland-cursor0_1.18.0-1_amd64.deb ...
Unpacking libwayland-cursor0:amd64 (1.18.0-1) ...
Selecting previously unselected package libwayland-egl1:amd64.
Preparing to unpack .../08-libwayland-egl1_1.18.0-1_amd64.deb ...
Unpacking libwayland-egl1:amd64 (1.18.0-1) ...
Selecting previously unselected package libxkbcommon0:amd64.
Preparing to unpack .../09-libxkbcommon0_0.10.0-1_amd64.deb ...
Unpacking libxkbcommon0:amd64 (0.10.0-1) ...
Selecting previously unselected package libgtk-3-common.
Preparing to unpack .../10-libgtk-3-common_3.24.20-0ubuntu1_all.deb ...
Unpacking libgtk-3-common (3.24.20-0ubuntu1) ...
Selecting previously unselected package libgtk-3-0:amd64.
Preparing to unpack .../11-libgtk-3-0_3.24.20-0ubuntu1_amd64.deb ...
Unpacking libgtk-3-0:amd64 (3.24.20-0ubuntu1) ...
Selecting previously unselected package libpangox-1.0-0:amd64.
Preparing to unpack .../12-libpangox-1.0-0_0.0.2-5ubuntu1_amd64.deb ...
Unpacking libpangox-1.0-0:amd64 (0.0.2-5ubuntu1) ...
Selecting previously unselected package libpangoxft-1.0-0:amd64.
Preparing to unpack .../13-libpangoxft-1.0-0_1.44.7-2ubuntu4_amd64.deb ...
Unpacking libpangoxft-1.0-0:amd64 (1.44.7-2ubuntu4) ...
Selecting previously unselected package libnspr4:amd64.
Preparing to unpack .../14-libnspr4_2%3a4.25-1_amd64.deb ...
Unpacking libnspr4:amd64 (2:4.25-1) ...
Selecting previously unselected package libnss3:amd64.
Preparing to unpack .../15-libnss3_2%3a3.49.1-1ubuntu1.5_amd64.deb ...
Unpacking libnss3:amd64 (2:3.49.1-1ubuntu1.5) ...
Selecting previously unselected package xdg-utils.
Preparing to unpack .../16-xdg-utils_1.1.3-2ubuntu1.20.04.2_all.deb ...
Unpacking xdg-utils (1.1.3-2ubuntu1.20.04.2) ...
Selecting previously unselected package libwayland-server0:amd64.
Preparing to unpack .../17-libwayland-server0_1.18.0-1_amd64.deb ...
Unpacking libwayland-server0:amd64 (1.18.0-1) ...
Selecting previously unselected package libgbm1:amd64.
Preparing to unpack .../18-libgbm1_20.2.6-0ubuntu0.20.04.1_amd64.deb ...
Unpacking libgbm1:amd64 (20.2.6-0ubuntu0.20.04.1) ...
Selecting previously unselected package libva2:amd64.
Preparing to unpack .../19-libva2_2.7.0-2_amd64.deb ...
Unpacking libva2:amd64 (2.7.0-2) ...
Selecting previously unselected package at-spi2-core.
Preparing to unpack .../20-at-spi2-core_2.36.0-2_amd64.deb ...
Unpacking at-spi2-core (2.36.0-2) ...
Selecting previously unselected package libigdgmm11:amd64.
Preparing to unpack .../21-libigdgmm11_20.1.1+ds1-1_amd64.deb ...
Unpacking libigdgmm11:amd64 (20.1.1+ds1-1) ...
Selecting previously unselected package intel-media-va-driver:amd64.
Preparing to unpack .../22-intel-media-va-driver_20.1.1+dfsg1-1_amd64.deb ...
Unpacking intel-media-va-driver:amd64 (20.1.1+dfsg1-1) ...
Selecting previously unselected package libipc-system-simple-perl.
Preparing to unpack .../23-libipc-system-simple-perl_1.26-1_all.deb ...
Unpacking libipc-system-simple-perl (1.26-1) ...
Selecting previously unselected package libfile-basedir-perl.
Preparing to unpack .../24-libfile-basedir-perl_0.08-1_all.deb ...
Unpacking libfile-basedir-perl (0.08-1) ...
Selecting previously unselected package libfile-desktopentry-perl.
Preparing to unpack .../25-libfile-desktopentry-perl_0.22-1_all.deb ...
Unpacking libfile-desktopentry-perl (0.22-1) ...
Selecting previously unselected package libfile-mimeinfo-perl.
Preparing to unpack .../26-libfile-mimeinfo-perl_0.29-1_all.deb ...
Unpacking libfile-mimeinfo-perl (0.29-1) ...
Selecting previously unselected package libgtk-3-bin.
Preparing to unpack .../27-libgtk-3-bin_3.24.20-0ubuntu1_amd64.deb ...
Unpacking libgtk-3-bin (3.24.20-0ubuntu1) ...
Selecting previously unselected package libio-stringy-perl.
Preparing to unpack .../28-libio-stringy-perl_2.111-3_all.deb ...
Unpacking libio-stringy-perl (2.111-3) ...
Selecting previously unselected package libxml-parser-perl.
Preparing to unpack .../29-libxml-parser-perl_2.46-1_amd64.deb ...
Unpacking libxml-parser-perl (2.46-1) ...
Selecting previously unselected package libxml-twig-perl.
Preparing to unpack .../30-libxml-twig-perl_1%3a3.50-2_all.deb ...
Unpacking libxml-twig-perl (1:3.50-2) ...
Selecting previously unselected package libnet-dbus-perl.
Preparing to unpack .../31-libnet-dbus-perl_1.2.0-1_amd64.deb ...
Unpacking libnet-dbus-perl (1.2.0-1) ...
Selecting previously unselected package libtie-ixhash-perl.
Preparing to unpack .../32-libtie-ixhash-perl_1.23-2_all.deb ...
Unpacking libtie-ixhash-perl (1.23-2) ...
Selecting previously unselected package libx11-protocol-perl.
Preparing to unpack .../33-libx11-protocol-perl_0.56-7_all.deb ...
Unpacking libx11-protocol-perl (0.56-7) ...
Selecting previously unselected package libxml-xpathengine-perl.
Preparing to unpack .../34-libxml-xpathengine-perl_0.14-1_all.deb ...
Unpacking libxml-xpathengine-perl (0.14-1) ...
Selecting previously unselected package mesa-va-drivers:amd64.
Preparing to unpack .../35-mesa-va-drivers_20.2.6-0ubuntu0.20.04.1_amd64.deb ...
Unpacking mesa-va-drivers:amd64 (20.2.6-0ubuntu0.20.04.1) ...
Selecting previously unselected package i965-va-driver:amd64.
Preparing to unpack .../36-i965-va-driver_2.4.0-0ubuntu1_amd64.deb ...
Unpacking i965-va-driver:amd64 (2.4.0-0ubuntu1) ...
Selecting previously unselected package va-driver-all:amd64.
Preparing to unpack .../37-va-driver-all_2.7.0-2_amd64.deb ...
Unpacking va-driver-all:amd64 (2.7.0-2) ...
Setting up liblcms2-2:amd64 (2.9-4) ...
Setting up libwayland-server0:amd64 (1.18.0-1) ...
Setting up libxml-parser-perl (2.46-1) ...
Setting up libtie-ixhash-perl (1.23-2) ...
Setting up libpangox-1.0-0:amd64 (0.0.2-5ubuntu1) ...
Setting up libpangoxft-1.0-0:amd64 (1.44.7-2ubuntu4) ...
Setting up libgbm1:amd64 (20.2.6-0ubuntu0.20.04.1) ...
Setting up libio-stringy-perl (2.111-3) ...
Setting up libxml-twig-perl (1:3.50-2) ...
Setting up libnet-dbus-perl (1.2.0-1) ...
Setting up libatspi2.0-0:amd64 (2.36.0-2) ...
Setting up libcolord2:amd64 (1.4.4-2) ...
Setting up libatk-bridge2.0-0:amd64 (2.34.2-0ubuntu2~20.04.1) ...
Setting up libva2:amd64 (2.7.0-2) ...
Setting up libigdgmm11:amd64 (20.1.1+ds1-1) ...
Setting up libepoxy0:amd64 (1.5.4-1) ...
Setting up libnspr4:amd64 (2:4.25-1) ...
Setting up libipc-system-simple-perl (1.26-1) ...
Setting up libxml-xpathengine-perl (0.14-1) ...
Setting up intel-media-va-driver:amd64 (20.1.1+dfsg1-1) ...
Setting up at-spi2-core (2.36.0-2) ...
Setting up libwayland-cursor0:amd64 (1.18.0-1) ...
Setting up libwayland-egl1:amd64 (1.18.0-1) ...
Setting up mesa-va-drivers:amd64 (20.2.6-0ubuntu0.20.04.1) ...
Setting up libsoup-gnome2.4-1:amd64 (2.70.0-1) ...
Setting up xdg-utils (1.1.3-2ubuntu1.20.04.2) ...
Setting up libx11-protocol-perl (0.56-7) ...
Setting up libgtk-3-common (3.24.20-0ubuntu1) ...
Setting up i965-va-driver:amd64 (2.4.0-0ubuntu1) ...
Setting up libxkbcommon0:amd64 (0.10.0-1) ...
Setting up librest-0.7-0:amd64 (0.8.1-1) ...
Setting up libfile-basedir-perl (0.08-1) ...
Setting up libnss3:amd64 (2:3.49.1-1ubuntu1.5) ...
Setting up va-driver-all:amd64 (2.7.0-2) ...
Setting up libfile-desktopentry-perl (0.22-1) ...
Setting up libfile-mimeinfo-perl (0.29-1) ...
Processing triggers for libglib2.0-0:amd64 (2.64.6-1~ubuntu20.04.3) ...
Setting up libgtk-3-0:amd64 (3.24.20-0ubuntu1) ...
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...
Setting up libgtk-3-bin (3.24.20-0ubuntu1) ...
Processing triggers for man-db (2.9.1-1) ...
Setting up mediacenter27 (27.0.84) ...
vmware@ubuntu20lts:~$ sudo dpkg -i MC27.0.84.deb
(Reading database ... 134755 files and directories currently installed.)
Preparing to unpack MC27.0.84.deb ...
Unpacking mediacenter27 (27.0.84over (27.0.84) ...
Setting up mediacenter27 (27.0.84) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for shared-mime-info (1.15-1) ...
vmware@ubuntu20lts:~$ 
Jriver 27 is now visible in the Music Servers section in the WEB GUI, I tick the box and press "Save and restart players".
I now login to the VNC server, with Remmina, VNC start up but there is no JRiver only the wall paper.
I have restarted Snakeoil but no luck.

The log have this line about Jriver:
After install
 
PHP Code:
[Sun Jun 27 12:25:17 2021mediacenter27[2874]: segfault at 10 ip 00007f2eb0c77610 sp 00007ffc290e43f0 error 4 in libJRTools.so[7f2eb0a4e000+387000

After reboot
 
PHP Code:
[Sun Jun 27 12:30:23 2021mediacenter27[1268]: segfault at 10 ip 000055933159d070 sp 00007ffcba5d8420 error 4 in mediacenter27[559330641000+1241000

I also updated to Snakeoil 1.2.1 just now and the same problem. Huh

Please advice, does anybody has any suggestion on how to solve this?
agent_kit, is this something you can solve to the next build?  Thanks

/Robert
Reply
#2
(27-Jun-2021, 09:00 PM)Primare11 Wrote: I have been using Snakeoil 1.1 with JRiver 25 as music server since 2019 with great result, it plays great and no problems whatsoever.  Smile Thumbs Up
Now when version 1.2 has been released I decided to try it out, in Vmware, it's much easier to install with the new script on top on Ubuntu server.
However I can't get Jriver 27 to start, I also have some dependency problems during install but I sort them out:
I'm using a remote KVM to work around this. Been meaning to write a blog about this, but still waiting for other misc parts to arrive before I can do it. Sad PiKVM allows me to load a ISO remotely and boot up a remote computer. It's really flexibile.

I suspect running a VM could be the issue for the fault. Make sure:
1. You are giving your virtual machine enough virtual memory
2. JRiver might be using some CPU extensions that is not enabled in your VM By default. Shut down your VM, go to settings, under Processor, enable all options (or one by one) and see if it works. Alternatively check what extensions JRiver needs and see if you can pass it through somehow. Proxmox gives me more flexibility to do this, unsure if VMWare Workstations do the same.
Snakeoil Operating System - Music, your way!
Reply
#3
(28-Jun-2021, 08:12 AM)agent_kith Wrote:
(27-Jun-2021, 09:00 PM)Primare11 Wrote: I have been using Snakeoil 1.1 with JRiver 25 as music server since 2019 with great result, it plays great and no problems whatsoever.  Smile Thumbs Up
Now when version 1.2 has been released I decided to try it out, in Vmware, it's much easier to install with the new script on top on Ubuntu server.
However I can't get Jriver 27 to start, I also have some dependency problems during install but I sort them out:
I'm using a remote KVM to work around this. Been meaning to write a blog about this, but still waiting for other misc parts to arrive before I can do it. Sad PiKVM allows me to load a ISO remotely and boot up a remote computer. It's really flexibile.

I suspect running a VM could be the issue for the fault. Make sure:
1. You are giving your virtual machine enough virtual memory
2. JRiver might be using some CPU extensions that is not enabled in your VM By default. Shut down your VM, go to settings, under Processor, enable all options (or one by one) and see if it works. Alternatively check what extensions JRiver needs and see if you can pass it through somehow. Proxmox gives me more flexibility to do this, unsure if VMWare Workstations do the same.

Thanks for the prompt replay.
I have the following settings in Vmware Workstation 
  • Memory = 4 GB
  • Processors = 2
    •  Options:
      •  Virtualize Intel VT-x/EPT or AMD-V/RVI
      •  Virtualize CPU performance counters
      •  Virtualize IOMMU (IO memory management unit)
I tried to disable/enable these, still the same error:
   [Mon Jun 28 15:35:03 2021] mediacenter27[1346]: segfault at 10 ip 000055d1bff03070 sp 00007ffcc854d380 error 4 in mediacenter27[55d1befa7000+1241000]
   [Mon Jun 28 15:38:31 2021] mediacenter27[1303]: segfault at 10 ip 000055a0e27ee070 sp 00007ffcfd058080 error 4 in mediacenter27[55a0e1892000+1241000]
   [Mon Jun 28 15:46:04 2021] mediacenter27[1301]: segfault at 10 ip 00005579eb219070 sp 00007ffcb75c2d80 error 4 in mediacenter27[5579ea2bd000+1241000]

However, I install Ubuntu 20.04 Mini (Desktop install where you select "mini" during the installation), with the exact same VMWare settings, and there Jriver starts up. Think

I also notice one thing, have you changed the windows manager to IceVM since Snakeiol 1.1, wasn't another windows manager used then?
If yes, can that be the problem?

II did an search on Jriver and segfault and found this: https://yabb.jriver.com/interact/index.p...#msg707248
It's quite old, but they talk about a display driver, has that been updated in Snakeoil 1.2?

I will try to test some more during the week.


/Robert
Reply
#4
(29-Jun-2021, 12:20 AM)Primare11 Wrote: I also notice one thing, have you changed the windows manager to IceVM since Snakeiol 1.1, wasn't another windows manager used then?
If yes, can that be the problem?

II did an search on Jriver and segfault and found this: https://yabb.jriver.com/interact/index.p...#msg707248
It's quite old, but they talk about a display driver, has that been updated in Snakeoil 1.2?

I will try to test some more during the week.
That means it's not a CPU extension that is causing the issue. Look under graphics and see if you can either:
1. Pass through your graphics card into this VM (make sure IOMMU is enabled)
2. Enable 3D graphics

See if JRiver will behave properly now in a VM. If all else fails you probably have to run this without virtualisation.

In theory JRiver can do some checks to make sure it has all it's hardware it needs and not seg fault like this. Look for any JRiver log file and see if actually says what the problem is.

Snakeoil always have been using IceVM. It's kind of a bad windows manager, but it's quick to load up and have minimal memory resources, and have a GUI that is more or less usable.
Snakeoil Operating System - Music, your way!
Reply
#5
(29-Jun-2021, 06:48 AM)agent_kith Wrote:
(29-Jun-2021, 12:20 AM)Primare11 Wrote: I also notice one thing, have you changed the windows manager to IceVM since Snakeiol 1.1, wasn't another windows manager used then?
If yes, can that be the problem?

II did an search on Jriver and segfault and found this: https://yabb.jriver.com/interact/index.p...#msg707248
It's quite old, but they talk about a display driver, has that been updated in Snakeoil 1.2?

I will try to test some more during the week.
That means it's not a CPU extension that is causing the issue. Look under graphics and see if you can either:
1. Pass through your graphics card into this VM (make sure IOMMU is enabled)
2. Enable 3D graphics

See if JRiver will behave properly now in a VM. If all else fails you probably have to run this without virtualisation.

In theory JRiver can do some checks to make sure it has all it's hardware it needs and not seg fault like this. Look for any JRiver log file and see if actually says what the problem is.

Snakeoil always have been using IceVM. It's kind of a bad windows manager, but it's quick to load up and have minimal memory resources, and have a GUI that is more or less usable.

In VMware the following is already set:
  • IOMMU
  • Accelerated 3D graphics
I cant find any Jriver log file, i have search for any file named jriver but no hit.

It is working in VMWare in Ubuntu 20.04 mini, that has the exact same vmware settings, the only difference should be that there is a desktop environment installed right and some package in that desktop environment is what Jriver needs to start, right?
But the next step will to see if it works in real PC.
Reply
#6
(30-Jun-2021, 12:37 AM)Primare11 Wrote: It is working in VMWare in Ubuntu 20.04 mini, that has the exact same vmware settings, the only difference should be that there is a desktop environment installed right and some package in that desktop environment is what Jriver needs to start, right?
But the next step will to see if it works in real PC.
Could be. But we are just guessing, it's very hard to tell because that segfault doesn't really give us much to go on. JRiver log file (if it exists) should tell us exactly what's happening.
Snakeoil Operating System - Music, your way!
Reply
#7
(30-Jun-2021, 12:29 PM)agent_kith Wrote:
(30-Jun-2021, 12:37 AM)Primare11 Wrote: It is working in VMWare in Ubuntu 20.04 mini, that has the exact same vmware settings, the only difference should be that there is a desktop environment installed right and some package in that desktop environment is what Jriver needs to start, right?
But the next step will to see if it works in real PC.
Could be. But we are just guessing, it's very hard to tell because that segfault doesn't really give us much to go on. JRiver log file (if it exists) should tell us exactly what's happening.

I have done some digging and found this:
In Ubuntu Mini I found the following log files in jriver directories:
- /home/vmware/.jriver/Media Center 27/Web/Log.txt
- /home/vmware/.jriver/Media Center 27/Web/Cache/LOG
- /home/vmware/.jriver/Media Center 27/Web/Cache/LOG.old

According to this info https://wiki.jriver.com/index.php/Logging you have to turn on logging.
after turning on logging is there a new log file here:
- /home/vmware/.jriver/Media Center 27/Log.txt
But in Snakeoil is there no Log files at all, not even the Web folder, so it looks like Jriver crash during startup before it can create folders an log files. Sad

The next step will be to install Snakeoil on a real PC and see if it's works.
[-] The following 1 user Likes Primare11's post:
  • agent_kith
Reply
#8
(01-Jul-2021, 12:27 AM)Primare11 Wrote: - /home/vmware/.jriver/Media Center 27/Log.txt
It's running as root. so try look in:
Code:
/root/.jriver/Media Center 27
Snakeoil Operating System - Music, your way!
Reply
#9
Sorry, no hit.
In the ~/.jriver/Media Center 27 folder is the following folders 
PHP Code:
root@ubuntu20lts:~/.jriver/Media Center 27# ls -l
total 24
drwxr
-xr-x 2 root root 4096 Jun 27 12:25 Data
drwxr
-xr-x 2 root root 4096 Jun 27 12:30 Library
drwxr
-xr-x 2 root root 4096 Jun 27 12:30 Settings
drwxr
-xr-x 4 root root 4096 Jun 27 12:25 Skins
drwxr
-xr-x 2 root root 4096 Jul  1 15:33 Temp
drwxr
-xr-x 4 root root 4096 Jun 27 12:25 Visualizations 
I can't find any Log.txt or similar file in any of those folders, all files except Temp was created when I install Jriver, and the Temp folder is empty.

So, I will try to install Snakeoil on a real PC and see if it's works.
[-] The following 1 user Likes Primare11's post:
  • agent_kith
Reply
#10
(02-Jul-2021, 12:09 AM)Primare11 Wrote: Sorry, no hit.
In the ~/.jriver/Media Center 27 folder is the following folders 
 
PHP Code:
root@ubuntu20lts:~/.jriver/Media Center 27# ls -l
total 24
drwxr
-xr-x 2 root root 4096 Jun 27 12:25 Data
drwxr
-xr-x 2 root root 4096 Jun 27 12:30 Library
drwxr
-xr-x 2 root root 4096 Jun 27 12:30 Settings
drwxr
-xr-x 4 root root 4096 Jun 27 12:25 Skins
drwxr
-xr-x 2 root root 4096 Jul  1 15:33 Temp
drwxr
-xr-x 4 root root 4096 Jun 27 12:25 Visualizations 
I can't find any Log.txt or similar file in any of those folders, all files except Temp was created when I install Jriver, and the Temp folder is empty.

So, I will try to install Snakeoil on a real PC and see if it's works.

I have now install Ubuntu server 20.04 and Snakeoil 1.2.1 + Jriver 27 on an old NUC5 if have, but it's still the same problem; mediacenter27 segfault 10 error 4. Sad
I have also tried to install both Jriver 25 (that I has running on Snakeoil 1.1) and Jriver 28 but none of them is showing up in the Snakeoil media servers list, so I cant start them.
Is there any way to manually enable Jriver 25 so it starts automatically or manually (just to try to narrow down the problem)?   
or is it possible to add the possibility to enable Jriver 25 and Jriver 28 in the next Snakeoil release?  Thanks
Reply


Bookmarks

Possibly Related Threads…
Thread Author Replies Views Last Post
  [split] Trouble Mounting CIFS share in 1.2.0 (Gear Isolation) Steely 4 159 23-May-2021, 06:22 PM
Last Post: Bromf
  Snakeoil Gear Isolation Alpha Series - Unable to access Web Interface musicnut23 10 792 22-Apr-2021, 07:16 PM
Last Post: musicnut23
  [SOLVEDCan't connect via VNC or install JRiver Primare11 5 1,546 23-Jul-2019, 08:54 AM
Last Post: agent_kith
  Jriver Media Center 23 Not receiving sound card diepgs 6 1,673 27-May-2019, 09:46 AM
Last Post: diepgs
  [SOLVEDJRiver 22 not working with Snakeoil OS agent_kith 17 6,665 18-Jul-2017, 08:57 PM
Last Post: agent_kith



Users browsing this thread: 1 Guest(s)
[-]
Sponsor

[-]
Latest Threads
Add RompR or/and O!MPD
Last Post: Primare11
24-Jul-2021 03:40 PM
» Replies: 2
» Views: 29
New look Forum
Last Post: agent_kith
24-Jul-2021 03:29 PM
» Replies: 1
» Views: 14
JRiver 27 seg faults in Gear Isolation
Last Post: Primare11
22-Jul-2021 03:35 PM
» Replies: 20
» Views: 282
Squeezeboxserve always started in 1.2.x
Last Post: Snoopy8
21-Jul-2021 08:37 AM
» Replies: 2
» Views: 36
Ongoing status updates with new UI for G...
Last Post: agent_kith
21-Jul-2021 08:04 AM
» Replies: 6
» Views: 242

[-]
SnakeoilOS Mission Statement

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.


[-]
Random Quotes
upnp/dlna bridge for Roon
agent_kith's profile agent_kith
Hi!  Not sure if it's even possible, but is there a possibility to do something similar what sonore did with sonoreUPNP bridge? Right now it works wit...

>