Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
davemLMS not able to play MP3
#1
Hi,

A while back I got a new HD and built it up with the latest snakeoil and copied all my media across. Ubuntu 22.0.4.1 and (now) snakeoil 1.2.8.  All good. Though I soon noticed that I had some trouble playing mp3 media.....it has irritated me enough that I have started to look more closely. When attempting to play the files, I get an error in the server.log for every mp3 that I try to playSlim:Tonguelayer::Song::open (425) Error: Couldn't create command line for mp3 playback for [file:///media/music/.........]

It was suggested that LAME was missing. I confirmed and installed LAME which was an improvement. I can now play the mp3 files on my SB Boom but they dont play on my squeezelite Ralph on snakeoil.

Has anyone else noticed this with LMS and 1.2.8 ?

(14-Nov-2022, 01:18 PM)davem Wrote:  

increased the logging level;

[Image: image.png]

(sorry about the image, the forum s/w didnt like my log file...)
Reply

#2
Can you try Squeezelite 1.6.4 and see if that works? I am using that player, and vaguely remembers MP3 is working on that player.
Snakeoil Operating System - Music, your way!
Reply

#3
(16-Nov-2022, 08:34 AM)agent_kith Wrote: Can you try Squeezelite 1.6.4 and see if that works? I am using that player, and vaguely remembers MP3 is working on that player.

I did. But no luck. I tried all squeezelite versions and as soon as I tried to play a mp3 it would crash (a red X beside the status) and the player would disappear from iPeng. Nothing in the logs.

Thought that I would try mpd, so installed ncmpc client and played the same mp3. All good.

So it seems that the issue relates to mp3 on squeezelite (& hardware players before I manually installed LAME). Is installing LAME actually the correct thing to have done ?

Edit. Just discovered that I have some .m4a files and they play fine as well...
Reply

#4
(16-Nov-2022, 09:54 AM)davem Wrote: I did. But no luck. I tried all squeezelite versions and as soon as I tried to play a mp3 it would crash (a red X beside the status) and the player would disappear from iPeng. Nothing in the logs.

Thought that I would try mpd, so installed ncmpc client and played the same mp3. All good.

So it seems that the issue relates to mp3 on squeezelite (& hardware players before I manually installed LAME). Is installing LAME actually the correct thing to have done ?

Edit. Just discovered that I have some .m4a files and they play fine as well...
Can you go to LMS settings, under file formats, look for MP3 and see what/how it's configured/ See if you can use other codecs, e.g. FFMPEG and see if that works better.
Snakeoil Operating System - Music, your way!
Reply

#5
(18-Nov-2022, 05:25 PM)agent_kith Wrote:
(16-Nov-2022, 09:54 AM)davem Wrote: I did. But no luck. I tried all squeezelite versions and as soon as I tried to play a mp3 it would crash (a red X beside the status) and the player would disappear from iPeng. Nothing in the logs.

Thought that I would try mpd, so installed ncmpc client and played the same mp3. All good.

So it seems that the issue relates to mp3 on squeezelite (& hardware players before I manually installed LAME). Is installing LAME actually the correct thing to have done ?

Edit. Just discovered that I have some .m4a files and they play fine as well...
Can you go to LMS settings, under file formats, look for MP3 and see what/how it's configured/ See if you can use other codecs, e.g. FFMPEG and see if that works better.

You mean 'file types' ? Under MP3, the only option I have is Native or Disabled.
Reply

#6
Can you SSH to the machine, and run the following:
Code:
sudo apt update
sudo apt install -y ffmpeg
Then reboot the computer and see if you can play MP3s again?
Snakeoil Operating System - Music, your way!
Reply

#7
(20-Nov-2022, 11:39 AM)agent_kith Wrote: Can you SSH to the machine, and run the following:
 
Code:
sudo apt update
sudo apt install -y ffmpeg
Then reboot the computer and see if you can play MP3s again?

Thanks AK
 I installed ffmpeg and rebooted as requested.
No change unfortunately. In the SB player GUI it says that it plays but on iPeng the player disappears and the player goes to an error state (A pulsing red X in the status) in the snakeoil player GUI.
I set the player.streaming logging to debug but no log entries generated.
 
Tried a few versions.
Just for kicks, I thought that I would then try some different mp3's and they started playing !!
I pulled one of the offending files down to my desktop and it plays fine !
So it seems that squeezelite doesnt like SOME mp3's..that play fine elsewhere. hmmm
 
this one works
 
This one doesnt....
 
[edit - images are getting screwed up when viewed in the forum, so removed them]

The obvious difference is the CBR/VBR...I tried a few more CBR which were ok. Then I found another VBR which caused LMS to bomb out again.
So it seems that squeezelite doesnt like variable bit rate mp3 ???
Reply

#8
(20-Nov-2022, 02:18 PM)davem Wrote: Thanks AK
 I installed ffmpeg and rebooted as requested.
No change unfortunately. In the SB player GUI it says that it plays but on iPeng the player disappears and the player goes to an error state (A pulsing red X in the status) in the snakeoil player GUI.
I set the player.streaming logging to debug but no log entries generated.
 
Tried a few versions.
Just for kicks, I thought that I would then try some different mp3's and they started playing !!
I pulled one of the offending files down to my desktop and it plays fine !
So it seems that squeezelite doesnt like SOME mp3's..that play fine elsewhere. hmmm
 
this one works
 
This one doesnt....
 
[edit - images are getting screwed up when viewed in the forum, so removed them]

The obvious difference is the CBR/VBR...I tried a few more CBR which were ok. Then I found another VBR which caused LMS to bomb out again.
So it seems that squeezelite doesnt like variable bit rate mp3 ???
Unfortunately I don't have a lot of MP3s to experiment, the few I have all worked fine, and yet to check if they're CBR or VBR. This looks like a problem with the LMS that comes with Snakeoil. Can you try and download the latest version of LMS and see if that problem goes away?

Either that you can also send me a location of a VBR MP3 so I can try and recreate this later from my rig. You can find my email when you click on the "Generate Diagnostics File" button in the systems page.
Snakeoil Operating System - Music, your way!
Reply

#9
(21-Nov-2022, 08:03 AM)agent_kith Wrote:
(20-Nov-2022, 02:18 PM)davem Wrote:  
Unfortunately I don't have a lot of MP3s to experiment, the few I have all worked fine, and yet to check if they're CBR or VBR. This looks like a problem with the LMS that comes with Snakeoil. Can you try and download the latest version of LMS and see if that problem goes away?

Either that you can also send me a location of a VBR MP3 so I can try and recreate this later from my rig. You can find my email when you click on the "Generate Diagnostics File" button in the systems page.

Thanks.. running vers 8.3.0 which is the latest stable.
I will mail you a problematic mp3.
Reply

#10
(21-Nov-2022, 08:22 AM)davem Wrote: Thanks.. running vers 8.3.0 which is the latest stable.
I will mail you a problematic mp3.
Cool, let me know how that goes. Also, uninstall lame (sudo apt purge lame*), just use ffmpeg, and that should work for all media types.
Snakeoil Operating System - Music, your way!
Reply



Bookmarks

Possibly Related Threads…
Thread Author Replies Views Last Post
  [SOLVEDPlay Windows Media? RomanM 6 76 05-Oct-2022, 04:31 PM
Last Post: hkphantomgtr
  [SOLVEDfiles with samplerate 48.0 kHz play slow macmaroni 4 2,080 11-Apr-2018, 06:15 AM
Last Post: macmaroni



Users browsing this thread:
1 Guest(s)

[-]
Our Sponsors

[-]
Welcome
You have to register before you can post on our site.

Username/Email:


Password:





[-]
Latest Threads
Kernel Builder Updates
Last Post: agent_kith
Yesterday 03:43 PM
» Replies: 18
» Views: 512
Snakeoil Firmware - 1.2.8 (Gear Isolatio...
Last Post: hossamyazeed
Yesterday 03:31 PM
» Replies: 14
» Views: 748
LMS not able to play MP3
Last Post: agent_kith
Yesterday 08:52 AM
» Replies: 17
» Views: 138
Desktop environment
Last Post: agent_kith
Yesterday 08:47 AM
» Replies: 4
» Views: 40
[split] Cannot install Roon Bridge
Last Post: agent_kith
Yesterday 08:44 AM
» Replies: 1
» Views: 7
Horror Dashboard
Last Post: pommede
29-Nov-2022 04:32 PM
» Replies: 17
» Views: 255
Roonserver/Hqplayer do not install
Last Post: Tecko
27-Nov-2022 06:09 PM
» Replies: 4
» Views: 43
dsd output music player
Last Post: Snoopy8
26-Nov-2022 04:15 AM
» Replies: 3
» Views: 35
Diretta protocol
Last Post: Evach
21-Nov-2022 08:12 PM
» Replies: 2
» Views: 57
LMS song lyrics plugin
Last Post: Snoopy8
21-Nov-2022 05:51 AM
» Replies: 1
» Views: 14

[-]
SnakeoilOS Mission Statement

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.


Powered By MyBB, © 2002-2022 Melroy van den Berg.