Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

PCIe-USB card stopped working


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
Hi everyone,
This seems like a problem with either BIOS, Ubuntu/Snakeoil or my SOtM PCIe-USB card but I seem to have ruled them all out so I am stuck.

I've always used SOtM PCIe-USB card to connect to my DAC. While messing with a PCIe-network card, the PCIe-USB card started having sporadic problems then stopped working completely.

With my DAC (or a USB stick connected) in the SOtM USB card, the USB device is not detected under "lsusb" (upper screen) and on startup, I get messages like the lower screen; "Unable to enumerate USB device".

[Image: Screen_Shot_2018_06_12_at_5_41_35_pm.png]

So far I have tried:
BIOS: reverting to default and flashing in more recent BIOS
Snakeoil: reverting to old FW, swapping OS SSD for one with very old Snakeoil OS and running via ISO/Live CD on USB drive
PCI-USB card: Have tried 3 of them (all same model SOtM cards)
DAC & USB cable: Works fine if I plug into motherboard USB port
PCIe slots: Tried all 4 on my mobo; none work with USB card; all work with network card

Any ideas welcome.
Thanks kindly,
JD
 Reply
#2
(12-Jun-2018, 06:03 PM) JD1 Wrote: tried different PCI slot? or you have only 1?
i have the same card. never had problems


[Image: Screen_Shot_2018_06_12_at_5_41_35_pm.png]

So far I have tried:
BIOS: reverting to default and flashing in more recent BIOS
Snakeoil: reverting to old FW, swapping OS SSD for one with very old Snakeoil OS and running via ISO/Live CD on USB drive
PCI-USB card: Have tried 3 of them (all same model SOtM cards)
DAC & USB cable: Works fine if I plug into motherboard USB port
PCIe slots: Tried all 4 on my mobo; none work with USB card; all work with network card

Any ideas welcome.
Thanks kindly,
JD

 Reply
#3
(12-Jun-2018, 07:00 PM) traver02 Wrote:
(12-Jun-2018, 06:03 PM) JD1 Wrote: tried different PCI slot? or you have only 1?
i have the same card. never had problems

 


I've used these SOtM cards with Snakeoil for years; no such problems before.  Reckon I broke something while trying external power to the network card. Just can't figure out what I broke.  Tried all 4 slots. None work with SOtM cards but all of them work with network card.
 Reply
#4
How many USB ports does it have? Check the USB connector (look inside at the pins).. Looks like there's something wrong with the USB signalling, either the cable is not working well, or the connector(s) tracks are dirty/burnt out.

Look inside the USB port of your SOTM and check if any of the tracks are 'burnt' off (current too high?), or if there is some sort of 'gunk' in there (dog hair?)...
Snakeoil Operating System - Music, your way!
 Reply
#5
(12-Jun-2018, 09:35 PM) agent_kith Wrote: How many USB ports does it have? Check the USB connector (look inside at the pins).. Looks like there's something wrong with the USB signalling, either the cable is not working well, or the connector(s) tracks are dirty/burnt out.

Look inside the USB port of your SOTM and check if any of the tracks are 'burnt' off (current too high?), or if there is some sort of 'gunk' in there (dog hair?)...


Smile Dog hair was a good guess in my house but I tried 3 different SOtM cards and 2 different USB cables.  These SOtM cards require external clocks but I tried 2 different clocks. I also tried many different ways of powering the clocks and cards.
 Reply
#6
Go into snakeoil (blind testing beta), and check if the USB ports are enabled/disabled? If enabled, leave them on and reset. As weird as it seems, this looks like a software problem and not a hardware one.

Do you have another computer to test the SoTM cards? First make sure the card works. (Try windows, MacOS, etc).. then work back from there.
Snakeoil Operating System - Music, your way!
 Reply
#7
(13-Jun-2018, 07:13 AM) agent_kith Wrote: Go into snakeoil (blind testing beta), and check if the USB ports are enabled/disabled? If enabled, leave them on and reset. As weird as it seems, this looks like a software problem and not a hardware one.

Do you have another computer to test the SoTM cards? First make sure the card works. (Try windows, MacOS, etc).. then work back from there.


That was a good idea. It didn't work though. I agree it appears like a software problem, though it wouldn't have surprised me if I had damaged some hardware. Maybe I did that too because when I tried to re-enable my LAN port, I found that it no longer works. Initially, the problem presented as Squeezelite not starting. I thought maybe it won't start unless a DAC is detected. Moving back to the beta today, Squeezelite does now start...but can't see my DAC.

I don't have any other computers with PCIe slots but I have spare mobos so I'll assemble one to test the SOtM cards as you suggest.

Thanks for helping

JD
 Reply
#8
Stay tuned.  I discovered a major error in the user  Rolleyes  
Now working with my backup SOtM gear on same mobo (apart from one dropout). I'll reverse my mods to find the original problem.
 Reply
#9
(13-Jun-2018, 02:41 PM) JD1 Wrote: Stay tuned.  I discovered a major error in the user  Rolleyes 

Can we start a pool and guess what you did?

What will the winner get? [Image: admire.gif]
Snakeoil Operating System - Music, your way!
 Reply
#10
Managed to diagnose a faulty USB card. Why it became faulty or whether that is related to the faulty LAN port I don't know. Progress at least. Working now with a substitute USB card using original clock.

My bad was during the diagnosis. I swapped in a different card and clock but used the wrong frequency clock. Spent a full day tracking my self-made problem before getting back to the original problem. D'Oh!  Confused
 Reply
 
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Latest Threads
[-]
Advertising
[-]
Possibly Related Threads…
 

Users browsing this thread: 1 Guest(s)