Help  Search  Portal
 Portal  Search
Hello There, Mystery Audiophile!  Register  Login

rpcbind: cannot create socket for udp6 and tcp6


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
Bug 
For some reason booting Snake-oil from HD seems to halt after issueing below messages:
rpcbind: cannot create socket for udp6
rpcbind: cannot create socket for tcp6

Starting the same ISO using PXE works fine allthough I also get the same error messages

Any idea what the problem might be here?
I am using the same motherboard as you do (Jetway NF9C) and using the ISO version "snakeoil-i686-0.1.4"
 Reply
#2
(05-Nov-2016, 10:34 PM) Leonard Wrote: For some reason booting Snake-oil from HD seems to halt after issueing below messages:
rpcbind: cannot create socket for udp6
rpcbind: cannot create socket for tcp6

Starting the same ISO using PXE works fine allthough I also get the same error messages

Any idea what the problem might be here?
I am using the same motherboard as you do (Jetway NF9C) and using the ISO version "snakeoil-i686-0.1.4"

The 6 in udp6 and tcp6 means IPv6. v6 is more for people who are connecting to the Internet.


Double check if you have disabled tty1 from the web menu. If that option is disabled, you will not get a login prompt from the console (you are effectively running Snakeoil headless and the only way to get into the Snakeoil machine is via the web app or via ssh).
Follow The Music, Follow Snakeoil.
 Reply
#3
(06-Nov-2016, 08:22 AM) agent_kith Wrote: The 6 in udp6 and tcp6 means IPv6. v6 is more for people who are connecting to the Internet.


Double check if you have disabled tty1 from the web menu. If that option is disabled, you will not get a login prompt from the console (you are effectively running Snakeoil headless and the only way to get into the Snakeoil machine is via the web app or via ssh).


I don't think the problem has to do with IP6. Only that this is the last message I see on the conneced monitor before the system seems to get to a halt.
When starting from a live CD the system I get the same message but the system will keep on booting after that. The next message I get normally is "* Starting early crypto disks"
So I think the problem must be somewhere between these two steps.

I am not able to access the system via the web UI or telnet
 Reply
#4
Tried installing the 32 bit and 64 bit versions without succes. Also tried installing it on SSD and HD and different BIOS settings made no difference.
Is it related to the BIOS? What BIOS version and settings are you using for this NF9C board?
 Reply
#5
(06-Nov-2016, 07:30 PM) Leonard Wrote: I don't think the problem has to do with IP6. Only that this is the last message I see on the conneced monitor before the system seems to get to a halt.
When starting from a live CD the system I get the same message but the system will keep on booting after that. The next message I get normally is "* Starting early crypto disks"
So I think the problem must be somewhere between these two steps.

I am not able to access the system via the web UI or telnet

Seems there is a problem somewhere. But not sure what it is just yet. Can you give me a full list of your hardware specs?
 
(06-Nov-2016, 09:57 PM) Leonard Wrote: Tried installing the 32 bit and 64 bit versions without succes. Also tried installing it on SSD and HD and different BIOS settings made no difference.
Is it related to the BIOS? What BIOS version and settings are you using for this NF9C board?


Here's my BIOS setting for NF9C. The only thing that needs to be set really is to make sure your SATA is set to AHCI. For best results, reset your BIOS to the default first and then make the changes.

When booting from the SSD, can you see if your network link LED is lit or not?
Follow The Music, Follow Snakeoil.
 Reply
#6
(07-Nov-2016, 08:27 AM) agent_kith Wrote:
(06-Nov-2016, 07:30 PM) Leonard Wrote: I don't think the problem has to do with IP6. Only that this is the last message I see on the conneced monitor before the system seems to get to a halt.
When starting from a live CD the system I get the same message but the system will keep on booting after that. The next message I get normally is "* Starting early crypto disks"
So I think the problem must be somewhere between these two steps.

I am not able to access the system via the web UI or telnet

Seems there is a problem somewhere. But not sure what it is just yet. Can you give me a full list of your hardware specs?
 
(06-Nov-2016, 09:57 PM) Leonard Wrote: Tried installing the 32 bit and 64 bit versions without succes. Also tried installing it on SSD and HD and different BIOS settings made no difference.
Is it related to the BIOS? What BIOS version and settings are you using for this NF9C board?


Here's my BIOS setting for NF9C. The only thing that needs to be set really is to make sure your SATA is set to AHCI. For best results, reset your BIOS to the default first and then make the changes.

When booting from the SSD, can you see if your network link LED is lit or not?


I have updated the BIOS to the latest version. The network link LED is indeed blinking. Can it be the case that it has to do with not getting a proper IP address?
I have now finally managed to install the 64 bit version on the Atom board and get to work. However I had to use a screen and keyboard to login to the prompt and set my ipaddress manually (sudo ifconfig eth0 ....)

Using the 32-bit version I don't see a chance to login as the boot process seems to get stuck.
 Reply
#7
(08-Nov-2016, 09:46 AM) Leonard Wrote: I have updated the BIOS to the latest version. The network link LED is indeed blinking. Can it be the case that it has to do with not getting a proper IP address?

I suspect this is the case.

(08-Nov-2016, 09:46 AM) Leonard Wrote: I have now finally managed to install the 64 bit version on the Atom board and get to work. However I had to use a screen and keyboard to login to the prompt and set my ipaddress manually (sudo ifconfig eth0 ....)

Using the 32-bit version I don't see a chance to login as the boot process seems to get stuck.

Do you have a DHCP server set up properly in your network (Say a router)? One of the pre-requisites of Snakeoil is to have a DHCP server setup and configured.
Follow The Music, Follow Snakeoil.
 Reply
#8
(08-Nov-2016, 10:19 AM) agent_kith Wrote:  
(08-Nov-2016, 09:46 AM) Leonard Wrote: I have now finally managed to install the 64 bit version on the Atom board and get to work. However I had to use a screen and keyboard to login to the prompt and set my ipaddress manually (sudo ifconfig eth0 ....)

Using the 32-bit version I don't see a chance to login as the boot process seems to get stuck.

Do you have a DHCP server set up properly in your network (Say a router)? One of the pre-requisites of Snakeoil is to have a DHCP server setup and configured.


Yes I have a DHCP server set up. Normally it should give a fixed ip address based on the MAC address. This is working fine when booting via PXE.
 Reply
#9
(08-Nov-2016, 10:30 AM) Leonard Wrote: Yes I have a DHCP server set up. Normally it should give a fixed ip address based on the MAC address. This is working fine when booting via PXE.

Just so I get what your setup is, PXE booting means you're loading the Snakeoil OS from a tftp server, is that correct?

Try and remove/disable the tftp server dhcp option in your DHCP server, and see if normal boot up now works. Something appears to be tripping the network manager on Ubuntu, but at this point not sure what it is yet. Sad
Follow The Music, Follow Snakeoil.
 Reply
#10
(08-Nov-2016, 11:06 AM) agent_kith Wrote:
(08-Nov-2016, 10:30 AM) Leonard Wrote: Yes I have a DHCP server set up. Normally it should give a fixed ip address based on the MAC address. This is working fine when booting via PXE.

Just so I get what your setup is, PXE booting means you're loading the Snakeoil OS from a tftp server, is that correct?

Try and remove/disable the tftp server dhcp option in your DHCP server, and see if normal boot up now works. Something appears to be tripping the network manager on Ubuntu, but at this point not sure what it is yet. [Image: sad.png]


Correct. I am using TFTP. Switching off the DHCP server (and the PXE boot option in the BIOS) didn't help.

Is there a way to force a specific IP address as a boot parameter?
On my router I notice that the computer is transmitting packages but itdoesn't receive anything.
 Reply
 

Bookmarks
 

Users browsing this thread: 1 Guest(s)