Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

Raspberry Pi 3B+ : Support for Allo DigiOne (Signature)


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
Hi there

I am wondering what sort of HAT is supported as there must be a bunch of potential Raspberry Pi user looming around?  I am currently testing out ver 1.1.3.  What I am trying to achieve is to use Lumin app (from iPad) to feed music to the Pi that has the Allo's DigiOne Signature.

I am not seeing the Allo supported in Music Player - ALSA Output Devices

Any insight would be helpful, thanks in advance.

Cheers
 Reply
#2
You need to add the overlay for the Allo DigiOne Signature to /boot/config.txt.. (any device supported by current kernel should work)
If you ssh into your pi running Snakeoil and run...
Code:
nano /boot/overlays/README

you should find the dtoverlay that applies.
See here for  how I added the dtoverlay for a HiFiBerry digi+Pro.  I2S and I2C lines need to be activated too...
https://www.snakeoil-os.net/forums/Threa...01#pid1901

whilst ssh in run...
Code:
 
sudo raspi-config 

and activate I2S and I2C
https://pimylifeup.com/raspi-config-tool/
[-] The following 1 user Likes Bromf's post:
  • agent_kith
 Reply
#3
(19-Mar-2019, 06:27 PM) Bromf Wrote: You need to add the overlay for the Allo DigiOne Signature to /boot/config.txt.. (any device supported by current kernel should work)
If you ssh into your pi running Snakeoil and run...
Code:
nano /boot/overlays/README

you should find the dtoverlay that applies.
See here for  how I added the dtoverlay for a HiFiBerry digi+Pro.  I2S and I2C lines need to be activated too...
https://www.snakeoil-os.net/forums/Threa...01#pid1901

whilst ssh in run...
Code:
sudo raspi-config 

and activate I2S and I2C
https://pimylifeup.com/raspi-config-tool/ 


Thanks a lot Bromf !!
 Reply
#4
You're most welcome...
I am off for my 'ugly' sleep now but will check back in the morning to see how it went... Smile
 Reply
#5
(19-Mar-2019, 07:08 PM) Bromf Wrote: You're most welcome...
I am off for my 'ugly' sleep now but will check back in the morning to see how it went... Smile


Sweet dreams Bromf, thanks for your input.

Somehow, I put in the dtoverlay=allo-digione & enabled I2S and I2C in the CONFIG.TXT by removing the #(which is valid as this is in the README file), but in RASPI-CONFIG, interface sub-menu, there is no tab for I2S, only I2C, SPI, SSH etc.  In the web interface SNAKEOIL/    ALSA Output Devices, Client is still in RED cannot start client

grateful for any input, thx
 Reply
#6
Ah... yes I was going from memory there....no I2S to activate in raspi-config you are correct.
Have you entered allo-digione as the Name in Alsa Configuration in the Music Player tab of the Snakeoil web interface and rebooted ?

Can you post the full content of /boot/config.txt

Currently my kernel line in /boot/config.txt shows..
Code:
kernel=kernel-4.14.66-rt40-pi-snakeoil

 Reply
#7
(20-Mar-2019, 02:38 AM) Bromf Wrote: Ah... yes I was going from memory there....no I2S to activate in raspi-config you are correct.
Have you entered allo-digione as the Name in Alsa Configuration in the Music Player tab of the Snakeoil web interface and rebooted ?

Can you post the full content of /boot/config.txt

Currently my kernel line in /boot/config.txt shows..
Code:
kernel=kernel-4.14.66-rt40-pi-snakeoil



Here you go, thanks in advance !
Code:
 
# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details
kernel=kernel-4.14.66-rt40-pi-snakeoil
# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
dtparam=i2c_arm=on
dtparam=i2s=on
#dtparam=spi=on
# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=off
#enable_uart=1
dtoverlay=allo-digione

start_x=0

 Reply
#8
From my previous post...."Have you entered allo-digione as the Name in Alsa Configuration in the Music Player tab of the Snakeoil web interface and rebooted ?" ??

Not sure about the line in your boot/config.txt
Code:
start_x=0


This does not appear in mine.
 Reply
#9
(20-Mar-2019, 08:19 AM) Bromf Wrote: From my previous post...."Have you entered allo-digione as the Name in Alsa Configuration in the Music Player tab of the Snakeoil web interface and rebooted ?" ??

Not sure about the line in your boot/config.txt
Code:
start_x=0


This does not appear in mine. 


I did put down the "allo-digione" into the Music Player and rebooted, but it was shown in red, [HW:0,0], and mpd is not started nor I can launch "mpd --version" in command line.

below is from aplay -L 
Code:
 
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=sndallodigione
    snd_allo_digione,
    Default Audio Device
sysdefault:CARD=sndallodigione
    snd_allo_digione,
    Default Audio Device
dmix:CARD=sndallodigione,DEV=0
    snd_allo_digione,
    Direct sample mixing device
dsnoop:CARD=sndallodigione,DEV=0
    snd_allo_digione,
    Direct sample snooping device
hw:CARD=sndallodigione,DEV=0
    snd_allo_digione,
    Direct hardware device without any conversions
plughw:CARD=sndallodigione,DEV=0
    snd_allo_digione,
    Hardware device with all software conversions


I will try to burn a fresh sd card and try from scratch and report back.   Big Grin

(20-Mar-2019, 10:56 AM) bernardhung Wrote:
(20-Mar-2019, 08:19 AM) Bromf Wrote: From my previous post...."Have you entered allo-digione as the Name in Alsa Configuration in the Music Player tab of the Snakeoil web interface and rebooted ?" ??

Not sure about the line in your boot/config.txt
Code:
start_x=0


This does not appear in mine.  


I did put down the "allo-digione" into the Music Player and rebooted, but it was shown in red, [HW:0,0], and mpd is not started nor I can launch "mpd --version" in command line.

below is from aplay -L 
Code:
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=sndallodigione
    snd_allo_digione,
    Default Audio Device
sysdefault:CARD=sndallodigione
    snd_allo_digione,
    Default Audio Device
dmix:CARD=sndallodigione,DEV=0
    snd_allo_digione,
    Direct sample mixing device
dsnoop:CARD=sndallodigione,DEV=0
    snd_allo_digione,
    Direct sample snooping device
hw:CARD=sndallodigione,DEV=0
    snd_allo_digione,
    Direct hardware device without any conversions
plughw:CARD=sndallodigione,DEV=0
    snd_allo_digione,
    Hardware device with all software conversions


I will try to burn a fresh sd card and try from scratch and report back.   Big Grin 


Got this by clicking Cannot start server
Code:
 
**** 2019-03-20T10:57:31
**** MPD (v21)

Executable: cd /var/www;_NAME="allo-digione" _OUTPUT="hw:0,0" _FORMAT="dop" _OPTIONS=""  /var/www/players/mpd-v21/init /var/www/players/mpd-v21 2>&1;/var/www/players/mpd-v21/start /var/www/players/mpd-v21 2>&1;
/var/www/players/mpd-v21/mpd: error while loading shared libraries: libfaad.so.2: cannot open shared object file: No such file or directory


Undecided , thanks for any help.
 Reply
#10
(20-Mar-2019, 10:56 AM) bernardhung Wrote: Got this by clicking Cannot start server

Undecided , thanks for any help. 

Hi Bernard. Did mpd v21 work for you before? It seems to be missing a library now. Can you SSH into the pi, and run the following?

Code:
sudo ldconfig

Snakeoil Operating System - Music, your way!
 Reply
 
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Latest Threads
[-]
Advertising
[-]
Possibly Related Threads…
 

Users browsing this thread: 1 Guest(s)