Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

Mount error CIFS


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
An error is generated when mounting the resource CIFS (mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) From Windows the resource is visible and accessible (without a password).

Media:
//Rt-n65u/wd2_5/AUDIO     or (//192.168.1.1/
wd2_5/AUDIO)
Mount point: AUDIO
Mount type: CIFS


What am I doing wrong?

[Image: Share.jpg]

image host



[Image: err.jpg]

форматы картинок
 Reply
#2
(10-Feb-2018, 01:53 AM) somiac Wrote: An error is generated when mounting the resource CIFS (mount error(22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) ) From Windows the resource is visible and accessible (without a password).

Remove the text 'WORKGROUP' from CIFS. And try to mount again. The CIFS credentials is designed to mount shares that are password protected. Private shares require the 3 fields - username, password and workgroup.

If you are using a public share just leave all 3 blank.
Snakeoil Operating System - Music, your way!
 Reply
#3
Cleaned, the error is the same.
[Image: err1.jpg]
 Reply
#4
Interesting. Did you set up AUDIO as a public share, or password protected?

Can you show me the share configuration settings of that folder on your NAS?
Snakeoil Operating System - Music, your way!
 Reply
#5
I use an ASUS RT-N65U router with an external USB disk for NAS. Now the share is configured without a password. But I tried and with the password, specified login, password and working group in the CIFS settings. The mistake was the same.
[Image: Router.jpg]
 Reply
#6
Huh I wonder why it's not working. Can you ssh to your Snakeoil machine, and run the following command?
Code:
sudo mount.cifs //RT-N65U/AUDIO /media/music/


What happens then? Did the share mount properly, or is there an error message?
Snakeoil Operating System - Music, your way!
 Reply
#7
I connected the network drive with the command:
Code:
sudo mount.cifs //RT-N65U/wd2_5/AUDIO /media/music/

 All network resources are available and the file is played by the player.
 Reply
#8
(11-Feb-2018, 10:02 PM) somiac Wrote: I connected the network drive with the command:
Code:
sudo mount.cifs //RT-N65U/wd2_5/AUDIO /media/music/

All network resources are available and the file is played by the player. 

So the NAS part work, wonder why yours don't. Think I'd have a check on the CIFS part of things later today and see what the problem is.
Snakeoil Operating System - Music, your way!
 Reply
#9
Did you fix the problem?
 Reply
#10
(17-Feb-2018, 03:26 PM) somiac Wrote: Did you fix the problem?


Couldn't recreate the issue. It works for me - guest shares mount fine when all the three fields in credentials are left blank. I'm testing this on x64 system though. Are you using 64 as well, or 32 bits?
Snakeoil Operating System - Music, your way!
 Reply
 
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Latest Threads
[-]
Advertising
[-]
Possibly Related Threads...
 

Users browsing this thread: 1 Guest(s)