Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] SnakeOil OS suddenly refuses to boot. Help needed!
#1
Hello! [Image: smile.png]
I have installed SnakeOil OS on an old 5i5 Intel NUC's SSD, everything went smoothly and it sang beautifully. Smile The sound quality was amazing!

Alas, yesterday I have decided to upgrade the NUC's BIOS to the latest version (it is a long story why) and I have discovered that the SnakeOil OS suddenly would not boot any more! 
In BIOS, in both UEFi and Legacy boot sections, there are no bootable drives listed. Entering F10 boot selection shows no bootable drives.
I have tried all possible BIOS settings (secure boot is disabled, etc.), but no luck. [Image: sad.png]
I have decided to reinstall it, booted the install iso from USB flash drive, went through the whole install procedure, everything seemed fine, worked exactly as the first install, but upon reboot I'm still getting the message: "reboot and select proper boot device or insert boot media in selected boot device".
Any ideas?

PS
This is my NUC model, it has a 120GB SSD and 8GB of RAM:
https://www.notebookcheck.net/Intel-NUC-...978.0.html
 Go to solution Reply
#2
(03-Mar-2020, 10:22 AM)koko6969koki Wrote: Hello! [Image: smile.png]
I have installed SnakeOil OS on an old 5i5 Intel NUC's SSD, everything went smoothly and it sang beautifully. Smile The sound quality was amazing!

Alas, yesterday I have decided to upgrade the NUC's BIOS to the latest version (it is a long story why) and I have discovered that the SnakeOil OS suddenly would not boot any more! 
In BIOS, in both UEFi and Legacy boot sections, there are no bootable drives listed. Entering F10 boot selection shows no bootable drives.
I have tried all possible BIOS settings (secure boot is disabled, etc.), but no luck. [Image: sad.png]
I have decided to reinstall it, booted the install iso from USB flash drive, went through the whole install procedure, everything seemed fine, worked exactly as the first install, but upon reboot I'm still getting the message: "reboot and select proper boot device or insert boot media in selected boot device".
Any ideas?

PS
This is my NUC model, it has a 120GB SSD and 8GB of RAM:
https://www.notebookcheck.net/Intel-NUC-...978.0.html
Whats your SATA device settings? Set to AHCI or something else (e.g. some sort of RAID).

Try and reset your BIOS to the factory default and see how that goes. Once you can get your SSD detected as a boot device, I would think it'll work. Any settings in the CSM you think is the issue?
Snakeoil Operating System - Music, your way!
Reply
#3
(03-Mar-2020, 11:23 AM)agent_kith Wrote:
(03-Mar-2020, 10:22 AM)koko6969koki Wrote: Hello! [Image: smile.png]
I have installed SnakeOil OS on an old 5i5 Intel NUC's SSD, everything went smoothly and it sang beautifully. Smile The sound quality was amazing!

Alas, yesterday I have decided to upgrade the NUC's BIOS to the latest version (it is a long story why) and I have discovered that the SnakeOil OS suddenly would not boot any more! 
In BIOS, in both UEFi and Legacy boot sections, there are no bootable drives listed. Entering F10 boot selection shows no bootable drives.
I have tried all possible BIOS settings (secure boot is disabled, etc.), but no luck. [Image: sad.png]
I have decided to reinstall it, booted the install iso from USB flash drive, went through the whole install procedure, everything seemed fine, worked exactly as the first install, but upon reboot I'm still getting the message: "reboot and select proper boot device or insert boot media in selected boot device".
Any ideas?

PS
This is my NUC model, it has a 120GB SSD and 8GB of RAM:
https://www.notebookcheck.net/Intel-NUC-...978.0.html
Whats your SATA device settings? Set to AHCI or something else (e.g. some sort of RAID).

Try and reset your BIOS to the factory default and see how that goes. Once you can get your SSD detected as a boot device, I would think it'll work. Any settings in the CSM you think is the issue?

Thanks for the quick answer! Smile

Here are my BIOS settings, I have tried changing between AHCI and RAID, but no luck. Sad


[Image: IMG-7654.jpg]

[Image: IMG-7655.jpg]

[Image: IMG-7656.jpg]

[Image: IMG-7657.jpg]

As you can see, I have gradually disabled all other boot options (USB, network, etc), hoping that I'll help the BIOS to "concentrate" on booting from the SSD. Big Grin

My son just said that I could try to use some boot repair utility like this: https://sourceforge.net/p/boot-repair-cd/home/Home/

I'll try it and I'll report back.

We just have tried it and it didn't work! Sad
Reply
#4
Boot repair disc works where there is a software/drive configuration problem. It is not expected that it will resolve a hardware problem.
Note there are 2 versions of boot repair disc  32 bit and 64 bit for the appropriate architectures....do you know which you tried ?
Reply
#5
Thank you all!

I have solved my problem using this technique:

​​​​​​https://izzylaif.com/en/clear-up-bios-boot-menu-entries/

....with this tool that made things much easier:

https://www.boyans.net/

I first had to install Windows to do it.
[-] The following 2 users Like koko6969koki's post:
  • patricia1066, agent_kith
Reply
#6
I am using that generation intel NUC and was considering updating BIOS. I read the warnings, and how to recover it and decided not to! Even removing the BIOS jumpers doesn't restore function for recent users.  

How can they release such buggy code, and leave it up!

What BIOS number did you try, and what one is working now?
Reply
#7
I'm using the latest BIOS that was available for download at the time I started this thread.

My NUC is running headless, it is not easy to find out the exact BIOS version since I first have to locate the miniHDMI cable that I used during the SnakeOil installation. Big Grin

The problem was solved by removing old and unused bootloader infos from the BIOS NAND RAM (whatever it is! Smile ).
Reply


Bookmarks

Possibly Related Threads…
Thread Author Replies Views Last Post
  Problem with installing Snakeoil on Raspberry szczemirek 8 253 06-Aug-2021, 04:39 PM
Last Post: Bromf
  Should Cloud-Init be removed from SnakeOil? Snoopy8 1 42 14-Jul-2021, 08:19 AM
Last Post: agent_kith
  Snakeoil Gear Isolation Alpha Series - Unable to access Web Interface musicnut23 10 805 22-Apr-2021, 07:16 PM
Last Post: musicnut23
  No IP Address (and no Version number) after boot on Asrock z490m-itx/ac motherboard oskar 1 312 26-Feb-2021, 09:22 AM
Last Post: agent_kith
  Why do a backup of SnakeOil ? Snoopy8 3 448 31-Jan-2021, 10:54 AM
Last Post: agent_kith



Users browsing this thread: 1 Guest(s)
[-]
Sponsor

[-]
Latest Threads
Ongoing status updates with new UI for G...
Last Post: agent_kith
Today 05:01 PM
» Replies: 23
» Views: 697
Snakeoil Firmware - 1.2.0 (Gear Isolatio...
Last Post: Bromf
Today 03:58 PM
» Replies: 15
» Views: 771
JRiver 28
Last Post: Primare11
Yesterday 12:48 AM
» Replies: 8
» Views: 43
Spotify Client
Last Post: agent_kith
21-Sep-2021 08:34 PM
» Replies: 42
» Views: 9388
intel nuc wifi drivers
Last Post: agent_kith
21-Sep-2021 04:13 PM
» Replies: 8
» Views: 72

[-]
SnakeoilOS Mission Statement

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.


[-]
Random Quotes
Merging Technologies: Butler Client
agent_kith's profile agent_kith
Trying to replicate LMS+Squeezelite over Ravenna. This is the Butler client, showing the source. Nothing in the Session sinks as I don't have any subscriber....

>