Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

files with samplerate 48.0 kHz play slow


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
Hi!

I'm still loving Snakeoil-OS, in fact, I'm back after a couple of weeks of trying out wtfplay, which I thought sounded better than Snakeoil until I came back just now!  Anyway, that's not why I'm writing here. I'm writing here because I couldn't figure out how to use the bug tracking system yet...

I just installed the 1.0.11 firmware, and re-tested a strange behavior I first noticed in 1.0.10, although it could have been there before.  When I play mp3 or FLAC files which have a 48 kHz sampling rate, they sound noticeably slower than expected, quite likely 44.1/48 (91.9%) as fast.  It sounds cool, like all the singers are huffing nitrous oxide, but it's probably not intended behavior for the player. It may be interesting to add that files with 88.2, 96 and 192 kHz sampling rates play perfectly.

It's easy to find 48 kHz files with the advanced search in LMS.  Just choose samplerate equals 48.0 kHz and click the Search button.  If you don't have any files encoded at that rate, I can email you some.

Thanks again for making such a great music player!
 Reply
#2
(10-Apr-2018, 07:50 AM) macmaroni Wrote: Hi!

I'm still loving Snakeoil-OS, in fact, I'm back after a couple of weeks of trying out wtfplay, which I thought sounded better than Snakeoil until I came back just now!  Anyway, that's not why I'm writing here. I'm writing here because I couldn't figure out how to use the bug tracking system yet...

I just installed the 1.0.11 firmware, and re-tested a strange behavior I first noticed in 1.0.10, although it could have been there before.  When I play mp3 or FLAC files which have a 48 kHz sampling rate, they sound noticeably slower than expected, quite likely 44.1/48 (91.9%) as fast.  It sounds cool, like all the singers are huffing nitrous oxide, but it's probably not intended behavior for the player. It may be interesting to add that files with 88.2, 96 and 192 kHz sampling rates play perfectly.

It's easy to find 48 kHz files with the advanced search in LMS.  Just choose samplerate equals 48.0 kHz and click the Search button.  If you don't have any files encoded at that rate, I can email you some.

Thanks again for making such a great music player!

What audio device are you using again?

This is usually the case when the audio card is 'rate locked'. I do own an old SB16 card where it's S/PDIF output can only do 48 kHz and it's multiples (resulting in a higher pitch). And looks like yours is the opposite - rate locked to 44.1 kHz.

Can you SSH into your computer, and run
Code:
sudo alsamixer


screen cap the picture of all the outputs? Hopefully there is an option to unlock the rate lock. Also check the music player menu, when playing music, what rate is it displaying? (You need to hit the refresh button to retreive the lasted audio stats).
Snakeoil Operating System - Music, your way!
 Reply
#3
Thank you for the quick response!

When I got home and started my SnakeOil-OS laptop just now, all the 48 kHz files are playing at the right speed.  I had the slow playback issue for about a week in firmware version 1.0.10 with restarts every morning.  But now that everything is working as expected, it's probably not necessary to wonder why too much. 

I'm using a Chord Mojo DAC, which so far has been very good at changing sample rates on the fly.

Here's the screenshot, just for fun.  I love being able to ssh into the music server, another great
feature.

[Image: Screenshot_from_2018_04_09_19_26_47.png]
[-] The following 1 user Likes macmaroni's post:
  • agent_kith
 Reply
#4
(10-Apr-2018, 10:45 AM) macmaroni Wrote: Thank you for the quick response!

When I got home and started my SnakeOil-OS laptop just now, all the 48 kHz files are playing at the right speed.  I had the slow playback issue for about a week in firmware version 1.0.10 with restarts every morning.  But now that everything is working as expected, it's probably not necessary to wonder why too much. 

I'm using a Chord Mojo DAC, which so far has been very good at changing sample rates on the fly.

Here's the screenshot, just for fun.  I love being able to ssh into the music server, another great
feature.

[Image: Screenshot_from_2018_04_09_19_26_47.png]


Good to know. If you have this problem again, try and power off the Chord completely, wait 10 seconds then re-power it up. If you havn't changed anything on Snakeoil then the rate lock is a hardware issue and not a computer one.

However, if you have created your own .alsaconf then something like rate lock can happen.
Snakeoil Operating System - Music, your way!
 Reply
#5
Thanks, that's all useful information!  If I learn any more about what happened, I'll try to get back here and report it, but of course the internet is so big, it's easy to get lost.  If nobody hears from me in 5 quadrillion nanoseconds, send out the search engines!
 Reply
 
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Latest Threads
[-]
Advertising
[-]
Possibly Related Threads…
 

Users browsing this thread: 1 Guest(s)