Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

nvme storage not found during installation steps - Intel NUC


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
Hi everyone!!!

I can't wait to get snakeoil on my newly purchased Intel NUC but running into some issues finding the nvme storage device during install.

 It's a 10th gen Intel NUC, a BXNUC10I5FN. The nvme drive is a WD Blue SN550 1TB NVMe M.2. AHCI set in bios. Legacy boot enable.

I've used etcher and unetbootin tools to copy iso to usb key, it does boot and I get to start the Ubuntu installation process. However, I get varying results through legacy boot (rufus doesn't work at all).
a) Unetbootin - At the drive selection screen, it shows nothing in the partition window. This is with standard and updated kernels.
b) Etcher - At the drive selection screen, it shows the USB partitions in the partition window.

For both Unetbootin and Etcher, lsblk and df don't show the nvme device. There was strangely only one time that I saw the /sdb device to install but the installation window using the Unetbootin key but closed after. I haven't seen the /sdb device since.

More interestingly, I found a standard Ubuntu usb key I already had. I popped it in and the nvme storage was found successfully and I've successfully installed Ubuntu.

Hope you can help, can't wait to see snakeoil!!!!!

@agent_kith @Snoopy8

I should have searched first, looks like I should try these two kernels? It's been a number of hours of troubleshooting.....3:37am over here......Will try again tomorrow *yawn*

NVME - Add support for NVME SSDs. Works with Intel I210 NIC (Last update: 2018-04-25)
[Image: zip.png]   install-4.4.9-rt17-amd64-nvme.zip (Size: 3.66 MB / Downloads: 32) 

NAS
Use this kernel and you can turn your Snakeoil PC into a basic NAS.
[Image: tar.png]   vmlinuz-4.4.9-rt17-amd64-nas.tar.bz2 (Size: 3.59 MB / Downloads: 2)
 Go to solution  Reply
#2
It's found the nvme storage!!!!!!!!!! :)

Ok, spoke too soon, just came up with "Unable to install GRUB in /dev/nvme" "Executing 'grub-install /dev/nvme' failed. This is a fatal error. :(
 Reply
#3
Fixed the grub boot, it now boots in

But no ethernet or wireless.

Pulling my hair out. Tried to follow this instructions for the Intel NIC. https://www.intel.com/content/www/us/en/...ducts.html

But when I get to the 'make install' step, it says I don't have kdernal header files in any of the expected locations. Install the approapriate kernel development package, eg. kernel-devel

But without any internet access, apt get doesn't work Sad
 Reply
#4
I think my issue is the kernel i copied to install snakeoil so it supports nvme is based on an old kernel, 4.4.9 dataed 20180425 and hence when the ethernet isn't working.

@agent_kith , hope you or someone can help.
 Reply
#5
(03-Oct-2020, 12:11 PM) emptor Wrote: I think my issue is the kernel i copied to install snakeoil so it supports nvme is based on an old kernel, 4.4.9 dataed 20180425 and hence when the ethernet isn't working.

@agent_kith , hope you or someone can help.


Hi Emptor, according to the Internet the i219 network card uses the E1000E driver, which is included in the kernel.

I also you have managed to boot into the NUC with the NVME kernel, and have a working screen? If yes, can you run this command and take a picture of the output?
Code:
dmesg|grep -i e1000e



I have some backlog Snakeoil support stuffs to clear, and will be going out later today, but will try and do up a test kernel for you later when I can. Will email it to you to test.
Snakeoil Operating System - Music, your way!
[-] The following 1 user Likes agent_kith's post:
  • emptor
 Reply
#6
Hey @agent_kith , thanks so much for helping out. Yep, I've also read it's the E1000E driver that should work with the I-219 NIC.

After failing at the boot loader step of the installation (which I've read your reply on another thread it's due to not being able to access the internet which makes sense), if I reboot, it doesn't load.

So what I did was follow the steps here https://help.ubuntu.com/community/Boot-Repair to automatically fix.

When I do this, I get back into same Debian GUI as during the installation process but of course, without the installer automatically popping up. It's booted from the NVME without the USB live key.

I've never seen the prompt for the snakeoil test login with 192.168.0.1.

The output of dmesg|grep -i e1000e is:

[    1.239051] e1000e: Intel® PRO/1000 Network Driver - 3.2.6-k
[    1.239186] e1000e: Copyright© 1999 - 2015 Intel Corporation.

Can't wait to get snakeoil going!!!!!!! Smile Thanks once again.

ifconfig -a doesn't show the eth, just lo and sit0.


[Image: rps20201004-123822.jpg]

Also, not sure if it helps, but when I run lshw -c NET, I get the follow unclaimed messages for both the network controller and ethernet controller

[Image: rps20201004-124835.jpg]

sudo modprobe e1000e comes up with some errors:

[Image: rps20201004-131244.jpg]

Can't sudo apt install any updates without internet which makes it tricky.
 Reply
#7
Can you try this kernel and see if it detects your network card? It doesn't have NVMe support so you still can't install, but if the ethernet card is working with this kernel, I'll put up a kernel from this series with NVMe support and it'll be good to go.

As for modprobe, all the modules (aka drivers) are compiled statically... So in a sense you have one big kernel file, rather than a small kernel but with multiple drivers as .ko files sitting in the file system. A static (or mostly static) kernel seems to sound better. So it seems to have a driver built right into the kernel has that little bit extra advantage when compared to runing as a module.

The problem with this is the myraid of problems with driver support - as you can see first hand :(

This is one of the biggest hurdle to people using Snakeoil, something I will hopefully address eventually. In the mean time, I appreciate your patience getting this to work. :) Let me know how it goes with that kernel. Hoping with a working Internet, the installer will be able to download the right GRUB boot loader, so you don't have to run boot repair (In theory you only need to do this if you're using EFI). I believe EFI with CSM configured will still use the EFI grub boot-loader. I boot in BIOS so don't have this problem.
Snakeoil Operating System - Music, your way!
 Reply
#8
Hey @agent_kith !

No need to thank me. I was starting to think I should have got a standard SSD drive. I thank you for your time to get this to work.

One thing I forgot to mention (and I've just tried it again just to be sure) was I already tried this kernel right at the beginning.

When it boots in and the auto installer pops up, I can bring up a terminal window. ifconfig -a still only shows the lo and the sit0, no ethernet unfortunately.

I remember snoopy having some similar issues but it came up finally?

The NUC and the ethernet cable is ok as I can install standard Ubuntu and able to connect with the ethernet.

Here's a screenshot of the 20.04 LTS Ubuntu output of dmesg | grep -i e1000e and uname -r kernel 5.4.0-26-generic

[Image: rps20201005-164548.jpg]
 Reply
#9
Hey @agent_kith , hopefully I was able to provide enough info above to be able to troubleshoot? I'm dreaming of seeing the snakeoil interface, well, actually, dreaming of seeing my ethernet show up in the installation process. lol

Thanks heaps.
 Reply
#10
Hope you are ok @agent_kith ? Haven't heard from you for a few days.

Getting my NUC running is secondary to what's going on in this crazy world these days, especially here in Melbourne.

I hope to join the snakeoil family soon, my NUC is sitting here quietly and waiting.................
 Reply
 

Bookmarks
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Advertising
[-]
Possibly Related Threads…
 

Users browsing this thread: 1 Guest(s)