Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

upmpdcli and MPD


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
I installed upmpdcli in order to play DSD and PCM files from Audirvana+, which indeed recognizes UpMpd.

Assuming that upmpdcli eventually uses MPD as music player: which version of MPD is used?

I am asking because:
- choosing upmpdcli on the Music Player page cancels the previous choice of MPD version;
- so far I could only play 16bit PCM (higher bitrates just give a loud hiss);
- so far I have not been able to play DSD.

So I would try different MPD versions so that I can eventually play DSD and 24bit PCMfiles.

I could uninstall all MPD versions but one and then assume that upmpdcli is using the remaining one, but thought I'd better ask first.

Update: DSD files now playing well!

(Question still stands, as PCM maximizes at 16bit.)
 Reply
#2
(15-Jan-2018, 09:01 PM) bodiebill Wrote: I installed upmpdcli in order to play DSD and PCM files from Audirvana+, which indeed recognizes UpMpd.

Assuming that upmpdcli eventually uses MPD as music player: which version of MPD is used?

Right now it's always hard coded to use mpd-git. Future releases will be more flexible.
 
(15-Jan-2018, 09:01 PM) bodiebill Wrote: (Question still stands, as PCM maximizes at 16bit.) 

Think Not exactly sure what the loud hiss is. Normally I only get that when it's playing DSD but there is software volume control being applied somewhere. Some suggestions:
  1.  Check there all software volume control is set to 100%
  2. Select mpd-git and play a high res file. does it work?
I'm trying to get 1.0.8 released (have trouble uploading because my home internet is too slow). This version has a newer MPD (2.0.15). Hopefully that will help. Try 1.0.8 (when it's available) if the above two troubleshooting steps aren't helping.
Snakeoil Operating System - Music, your way!
 Reply
#3
Thanks, will try the new fw when I get the chance. Regarding the PCM 24bit problem I found the following on the upmpdcli website:
https://www.lesbonscomptes.com/upmpdcli/upmpdcli-manual.html#_notes_on_the_tidal_interface 
where it says:
You should know that MPD has difficulties with some formats when accessed through HTTP which is how the Media Server transfers the data. Specifically, WAV and AIFF files, especially with samples wider than 16 bits are a frequent source of trouble (because they are little used and little tested for streaming). Support will vary depending on the MPD versions and exactly what input plugins are configured (among ffmpeg, libaudiofile and libsndfile). Often, the same files play just fine locally, it’s the combination of HTTP access and file format which causes problems.

I upgraded to fw 1.0.8 and now PCM24 bit plays well!
At first DSD dis not play at all, but I just needed to change the streaming mode to DoP, so apparently 1.0.7 was able to do raw DSD, but 1.0.8 only does DoP.
Anyhow, glad that both formats now work, thanks!
[-] The following 1 user Likes bodiebill's post:
  • agent_kith
 Reply
#4
Good to know it works. Native DSD is always a hard nut to crack. This is more ALSA than MPD I think. Hopefully a newer version of ALSA will improve this down the road.
Snakeoil Operating System - Music, your way!
 Reply
#5
Hi Snakeoil community!
I am new in this space, also I have very limited knowledge of linux, so, please, bear with me Smile

I have just activated my Snakeoil to get regular access to minimserver and upmpdcli.
I know these tools as I use installation: minimal Arch Linux + mpd + upmpdcli + minimserver running all on the same PC.

I am not able to set up similar configuration with Snakeoil using WEB GUI only. Maybe, I am doing something wrong, maybe there is a bug there?

After I activate minimserver in "Music Servers" block, upmpdcli appears in "Music Clients" block - I activate it. Still, I cannot playback anything because there is no mpd running there. I tried to connect via ssh and started mpd manually from ssh. Everything works like a charm now.

Apparently, there should be some mpd running when upmpdcli is activated, but it is not. Is there a way how to set up Snakeoil so that I need not manually start mpd for upmpdcli?

Thank you for help Smile

PS: This is probably not the right place submitting following idea, but it makes sense in context of minimserver+upmpdcli+mpd. It makes sense to be able to start mpd without its own library and this ought to be an option chosen by user in WEB GUI.
 Reply
#6
(03-Oct-2019, 01:43 AM) [email protected] Wrote: Apparently, there should be some mpd running when upmpdcli is activated, but it is not. Is there a way how to set up Snakeoil so that I need not manually start mpd for upmpdcli?

That could be a bug. upmpdcli is supposed to auto-start MPD. I'll have a check on that later after work tonight.

Also, good idea to change your account name and remove the email address. You might get spammed, unless that email account is one of your worst enemies Big Grin.
Snakeoil Operating System - Music, your way!
 Reply
#7
(03-Oct-2019, 01:43 AM) [email protected] Wrote: Apparently, there should be some mpd running when upmpdcli is activated, but it is not. Is there a way how to set up Snakeoil so that I need not manually start mpd for upmpdcli?

Think I know what the problem is. Select MPD v21 as the player first, configure a ALSA output device, then save & start the player. Confirm MPD is working well.

Next, select upmpdcli, and it should auto start MPD now.

I'll figure out a way to fix this eventually. Not entirely sure this fix will be added in U8, but the above will get you started.
Snakeoil Operating System - Music, your way!
[-] The following 1 user Likes agent_kith's post:
  • eFeS
 Reply
#8
(03-Oct-2019, 08:27 PM) agent_kith Wrote:
(03-Oct-2019, 01:43 AM) [email protected] Wrote: Apparently, there should be some mpd running when upmpdcli is activated, but it is not. Is there a way how to set up Snakeoil so that I need not manually start mpd for upmpdcli?

Think I know what the problem is. Select MPD v21 as the player first, configure a ALSA output device, then save & start the player. Confirm MPD is working well.

Next, select upmpdcli, and it should auto start MPD now.

I'll figure out a way to fix this eventually. Not entirely sure this fix will be added in U8, but the above will get you started.


Thank you. The requence of steps you recommended solved the problem.
[-] The following 1 user Likes eFeS's post:
  • agent_kith
 Reply
 
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Latest Threads
[-]
Advertising
[-]
Possibly Related Threads…
 

Users browsing this thread: 1 Guest(s)