Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

Snakeoil Firmware - 1.1.11 (Blind Testing Update 11)


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
Introduction
A minor update. Apologies for the delay as I've been splitting my time trying to get my home Internet connection fixed, and also the website of our new Sponsor (Sublime Hifi).

Anyway, this release now allows you to backup/restore basic snakeoil configuration so you can transfer this to another machine (great for migrating to the next iteration of Snakeoil OS). Note this will only backup and restore the Snakeoil configuration, as well as MPD music databases. This backup will not touch your actual music files as that might be too big to transfer over the web browser (technically it's the uploading that is problematic, not downloading).


New to this release is the ability to disable uhubctl on your machines (some systems will freeze when uhubctl is querying the USB ports), Unchecking the option will instantly kill the uhubctl querying process which will restore the functionality of modifying the Snakeoil tweaks.
 
[Image: disable-uhubctl.png]

With this out of the way I'll be back on working on Snakeoil Gear Isolation. The hope is to finish porting the new WebApp and make the integration work again.

Download
.fw   snakeoil-1.1.11-armv7l.fw (Size: 12.64 MB / Downloads: 27) (SHA1: 2493faf6d8a5a09424870c195df12792c04700d3)
.fw   snakeoil-1.1.11-i686.fw (Size: 13.34 MB / Downloads: 13) (SHA1: 11e4406924c8bc4745dcf7d5ececf6d65b190972)
.fw   snakeoil-1.1.11-x86_64.fw (Size: 13.32 MB / Downloads: 86) (SHA1: 54a13a8def29a9212ef0a9eebf406afb884348d9)


ChangeLog
Snakeoil Operating System - Music, your way!
[-] The following 2 users Like agent_kith's post:
  • Snoopy8, Bromf
 Reply
#2
I did an update manually (via SnakeOil Dashboard, did not find 1.1.11) and it worked OK.  Using Intel NUC 8i5, e1000e network driver.
Sounds the same after upgrade.    Thumbs Up

Backup is working. Labels need to be updated...

[Image: image-2021-01-20-110253.png]

uhubctl option now showing in SnakeOil tab, but is not relevant for Intel NUC. Previously, could not find any programmable USB ports, so good to have this option off.

For "fun", decided to manually update from 16.04 to 18.04.  However, found that backup will not restore to previous version of Ubuntu; should it???

Added **
For further "fun" (NOT), I managed to destroy my image by upgrading to 20.04.  After a bit of runaround (long time since I did the last install!), I managed to install back to 1.1.11.  Can confirm that restore works!!!  Clap    Minor issue: list of available players needs to backed up and restored.

Also, CPUSet option not re-installed properly
[-] The following 1 user Likes Snoopy8's post:
  • hkphantomgtr
 Reply
#3
(20-Jan-2021, 09:14 AM) Snoopy8 Wrote: I did an update manually (via SnakeOil Dashboard, did not find 1.1.11) and it worked OK.  Using Intel NUC 8i5, e1000e network driver.
Sounds the same after upgrade.    Thumbs Up

Backup is working. Labels need to be updated...

[Image: image-2021-01-20-110253.png]

This could be a browser caching issue. Try and do a SHIFT-F5 (or equivalent) and see if it shows up.

(20-Jan-2021, 09:14 AM) Snoopy8 Wrote: uhubctl option now showing in SnakeOil tab, but is not relevant for Intel NUC. Previously, could not find any programmable USB ports, so good to have this option off.

For "fun", decided to manually update from 16.04 to 18.04.  However, found that backup will not restore to previous version of Ubuntu; should it???

Yeah, it only backups the Snakeoil configuration and nothing else. So you can't really restore back to 16.04 when you updated to 18.04...

Anything else and it will be too big and can't work over the web browser.

Do do what you want to do, you'll need to install Ubuntu with LVM, and use it's snapshot facilities. <- This may be something worth implementing in the future.

(20-Jan-2021, 09:14 AM) Snoopy8 Wrote: Added **
For further "fun" (NOT), I managed to destroy my image by upgrading to 20.04.  After a bit of runaround (long time since I did the last install!), I managed to install back to 1.1.11.  Can confirm that restore works!!!  Clap    Minor issue: list of available players needs to backed up and restored.

Hmm. Maybe I can make that an option... Will experiment around with this.

(20-Jan-2021, 09:14 AM) Snoopy8 Wrote: Also, CPUSet option not re-installed properly

Oh.. I'll see what I can do about that...
Snakeoil Operating System - Music, your way!
[-] The following 1 user Likes agent_kith's post:
  • Snoopy8
 Reply
#4
(20-Jan-2021, 09:14 AM) Snoopy8 Wrote: I did an update manually (via SnakeOil Dashboard, did not find 1.1.11) and it worked OK.  Using Intel NUC 8i5, e1000e network driver.
Sounds the same after upgrade.    Thumbs Up

Backup is working. Labels need to be updated...

[Image: image-2021-01-20-110253.png]

uhubctl option now showing in SnakeOil tab, but is not relevant for Intel NUC. Previously, could not find any programmable USB ports, so good to have this option off.

For "fun", decided to manually update from 16.04 to 18.04.  However, found that backup will not restore to previous version of Ubuntu; should it???

Added **
For further "fun" (NOT), I managed to destroy my image by upgrading to 20.04.  After a bit of runaround (long time since I did the last install!), I managed to install back to 1.1.11.  Can confirm that restore works!!!  Clap    Minor issue: list of available players needs to backed up and restored.

Also, CPUSet option not re-installed properly


Hi, snoopy8, may I know that did your machine run Snakeoil under 20.04 without any problem?  Thanks.
My snakeoil stopped working after upgraded to 20.04, even it's a fresh installation, in a few months ago.  FYI, https://www.snakeoil-os.net/forums/Threa...-20-04-LTS
 Reply
#5
(20-Jan-2021, 01:53 PM) hkphantomgtr Wrote: Hi, snoopy8, may I know that did your machine run Snakeoil under 20.04 without any problem?  Thanks.
My snakeoil stopped working after upgraded to 20.04, even it's a fresh installation, in a few months ago.  FYI, https://www.snakeoil-os.net/forums/Threa...-20-04-LTS

I should have read your thread before I tried! Steam

I could not even boot after upgrade; I suspect that my choice of not upgrading Grub caused the error.

(20-Jan-2021, 12:32 PM) agent_kith Wrote: This could be a browser caching issue. Try and do a SHIFT-F5 (or equivalent) and see if it shows up.

I use mainly Opera, did a refresh, no go. However, it is showing up properly in Firefox, Edge.

Problem also on Android Chrome browser.

(20-Jan-2021, 12:32 PM) agent_kith Wrote: Yeah, it only backups the Snakeoil configuration and nothing else. So you can't really restore back to 16.04 when you updated to 18.04...

Anything else and it will be too big and can't work over the web browser.

To do what you want to do, you'll need to install Ubuntu with LVM, and use it's snapshot facilities. <- This may be something worth implementing in the future.

OK, I'll look at LVM and other options...
(20-Jan-2021, 12:32 PM) agent_kith Wrote: Hmm. Maybe I can make that an option... Will experiment around with this.
...
Also, CPUSet option not re-installed properly
...
Oh.. I'll see what I can do about that...

These are nice to haves....
[-] The following 2 users Like Snoopy8's post:
  • hkphantomgtr, agent_kith
 Reply
#6
(20-Jan-2021, 03:02 PM) Snoopy8 Wrote:
(20-Jan-2021, 01:53 PM) hkphantomgtr Wrote: Hi, snoopy8, may I know that did your machine run Snakeoil under 20.04 without any problem?  Thanks.
My snakeoil stopped working after upgraded to 20.04, even it's a fresh installation, in a few months ago.  FYI, https://www.snakeoil-os.net/forums/Threa...-20-04-LTS

I should have read your thread before I tried! Steam

I could not even boot after upgrade; I suspect that my choice of not upgrading Grub caused the error.

(20-Jan-2021, 12:32 PM) agent_kith Wrote: This could be a browser caching issue. Try and do a SHIFT-F5 (or equivalent) and see if it shows up.

I use mainly Opera, did a refresh, no go. However, it is showing up properly in Firefox, Edge.

Problem also on Android Chrome browser.

(20-Jan-2021, 12:32 PM) agent_kith Wrote: Yeah, it only backups the Snakeoil configuration and nothing else. So you can't really restore back to 16.04 when you updated to 18.04...

Anything else and it will be too big and can't work over the web browser.

To do what you want to do, you'll need to install Ubuntu with LVM, and use it's snapshot facilities. <- This may be something worth implementing in the future.

OK, I'll look at LVM and other options...
(20-Jan-2021, 12:32 PM) agent_kith Wrote: Hmm. Maybe I can make that an option... Will experiment around with this.
...
Also, CPUSet option not re-installed properly
...
Oh.. I'll see what I can do about that...

These are nice to haves....


You're welcome, man Big Grin
[-] The following 1 user Likes hkphantomgtr's post:
  • Snoopy8
 Reply
#7
So will the new version fix my system always trying to detect programmable USB ports? I have a 32 bit MB and am a bit wary of going past 10 which sounds great in my system.

[Image: SNO-usb-port.png]
 Reply
#8
(22-Jan-2021, 08:36 PM) PKay Wrote: So will the new version fix my system always trying to detect programmable USB ports?

Yes it will. It annoyed me as well, but it does not appear affect the sound quality whether it is on or not.
 Reply
#9
(23-Jan-2021, 07:08 AM) Snoopy8 Wrote: Yes it will. It annoyed me as well, but it does not appear affect the sound quality whether it is on or not.

It does turn off the power to the assigned USB ports. So in all schemes of things it will reduce the power output. Good to have as you have removed one variable, however, didn't realise it's giving so much problems to some. In my setup it's either showing USB ports or none. I guess some motherboards is causing problems that is causing uhubctl to freeze.

So this is a workaround. Will try and update uhubctl in the next major release and hope that will bring better support.
Snakeoil Operating System - Music, your way!
 Reply
#10
(20-Jan-2021, 01:53 PM) hkphantomgtr Wrote: Hi, snoopy8, may I know that did your machine run Snakeoil under 20.04 without any problem?  Thanks.
My snakeoil stopped working after upgraded to 20.04, even it's a fresh installation, in a few months ago.  FYI, https://www.snakeoil-os.net/forums/Threa...-20-04-LTS

You should be trying 1.2 Gear Isolation Alpha3. I am now live on 20.04 and it sounds at least as good as 16.04.  Not going back, unless I find a big problem.
https://www.snakeoil-os.net/forums/Threa...68#pid4168
 Reply
 

Sponsors
[-]
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Possibly Related Threads…
 

Users browsing this thread: 1 Guest(s)