Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Snakeoil OS goes completely bonkers if you uninstall Logitech Media Server
#1
Hi all,

Not exactly sure why yet, but if you uninstall Logitech Media Server (LMS) on a Snakeoil machine, the whole system goes completely bonkers. I'm surprised by this bug, and also it's something I have never done before as I have been using LMS for a long time.

But for folks who have this problem, here's a quick fix (without re-installing the OS). The quick fix is to re-install LMS! [Image: lol2.gif]

You need to SSH (or direct console) to your computer, now run the following commands:
Code:
wget http://downloads.slimdevices.com/LogitechMediaServer_v7.9.3/logitechmediaserver_7.9.3_amd64.deb
Code:
sudo dpkg -i logitechmediaserver_7.9.3_amd64.deb
Code:
sudo reboot

Now Snakeoil OS will be back alive again. I will try and identify this bug when I can. But until then, try the above and let me know how it goes.
Snakeoil Operating System - Music, your way!
Reply
#2
(27-Oct-2020, 01:41 PM)agent_kith Wrote: Hi all,

Not exactly sure why yet, but if you uninstall Logitech Media Server (LMS) on a Snakeoil machine, the whole system goes completely bonkers. I'm surprised by this bug, and also it's something I have never done before as I have been using LMS for a long time.

But for folks who have this problem, here's a quick fix (without re-installing the OS). The quick fix is to re-install LMS! [Image: lol2.gif]

You need to SSH (or direct console) to your computer, now run the following commands:
Code:
wget http://downloads.slimdevices.com/LogitechMediaServer_v7.9.3/logitechmediaserver_7.9.3_amd64.deb sudo dpkg -i logitechmediaserver_7.9.3_amd64.deb sudo reboot

Now Snakeoil OS will be back alive again. I will try and identify this bug when I can. But until then, try the above and let me know how it goes.

Thanks a lot, Agent Kith!

1st)  these codes doesn't work in a single line.  I have to split into 3 lines, i.e.
Code:
 
wget http://downloads.slimdevices.com/LogitechMediaServer_v7.9.3/logitechmediaserver_7.9.3_amd64.deb
Code:
sudo dpkg -i logitechmediaserver_7.9.3_amd64.deb
2nd) and then the last one "reboot" doesn't work.  Because at such stage OS can't be turned off by command.  So the machine just keeps running but no response, and doesn't reboot.  We need to keep pressing the power button 6 sec to force it to shut down.   Then after power it, my SO is back to normal.

Anyway, I really appreciate your passion, enthusiasm, and kind heart. [Image: good_job.gif]
[-] The following 1 user Likes hkphantomgtr's post:
  • agent_kith
Reply
#3
(27-Oct-2020, 09:18 PM)hkphantomgtr Wrote: Anyway, I really appreciate your passion, enthusiasm, and kind heart. [Image: good_job.gif]
Didn't realise the code was all on a single line. Have fixed it..

Had some interesting finds yesterday:

There's no problem if I run the following command to uninstall LMS:
Code:
apt remove logitechmediaserver
Things will work as normal, and LMS is uninstalled. But something goes funky when I use the command purge.

Remove only uninstalls the binaries
Purge will remove binaries and configuration

Interesting thing is, why would Snakeoil fail when the configuration is removed? This is the question I hope I can find out.

Couldn't investigate further last night as I have a flat tyre on my car (this is my third flat this year btw!) One more and really I should have just replaced the set (the punctures can't be fixed so I have to get new tyres each time!)
Snakeoil Operating System - Music, your way!
Reply
#4
(28-Oct-2020, 08:53 AM)agent_kith Wrote:
(27-Oct-2020, 09:18 PM)hkphantomgtr Wrote: Anyway, I really appreciate your passion, enthusiasm, and kind heart. [Image: good_job.gif]
Didn't realise the code was all on a single line. Have fixed it..

Had some interesting finds yesterday:

There's no problem if I run the following command to uninstall LMS:
Code:
apt remove logitechmediaserver
Things will work as normal, and LMS is uninstalled. But something goes funky when I use the command purge.

Remove only uninstalls the binaries
Purge will remove binaries and configuration

Interesting thing is, why would Snakeoil fail when the configuration is removed? This is the question I hope I can find out.

Couldn't investigate further last night as I have a flat tyre on my car (this is my third flat this year btw!) One more and really I should have just replaced the set (the punctures can't be fixed so I have to get new tyres each time!)

This tough year is almost done.  Let's hope for a better year to come.    Big Grin
[-] The following 1 user Likes hkphantomgtr's post:
  • agent_kith
Reply
#5
(28-Oct-2020, 08:53 AM)agent_kith Wrote:
(27-Oct-2020, 09:18 PM)hkphantomgtr Wrote: Anyway, I really appreciate your passion, enthusiasm, and kind heart. [Image: good_job.gif]
Didn't realise the code was all on a single line. Have fixed it..

Had some interesting finds yesterday:

There's no problem if I run the following command to uninstall LMS:
Code:
apt remove logitechmediaserver
Things will work as normal, and LMS is uninstalled. But something goes funky when I use the command purge.

Remove only uninstalls the binaries
Purge will remove binaries and configuration

Interesting thing is, why would Snakeoil fail when the configuration is removed? This is the question I hope I can find out.

Couldn't investigate further last night as I have a flat tyre on my car (this is my third flat this year btw!) One more and really I should have just replaced the set (the punctures can't be fixed so I have to get new tyres each time!)

"Apt remove logitechmediaserver" works!  And SO keeps working normally after reboot.  Thank you very much again, Agent Kith!   Smile
[-] The following 1 user Likes hkphantomgtr's post:
  • agent_kith
Reply


Bookmarks

Possibly Related Threads…
Thread Author Replies Views Last Post
  Should Cloud-Init be removed from SnakeOil? Snoopy8 1 37 14-Jul-2021, 08:19 AM
Last Post: agent_kith
  Unable to uninstall MinimServer 0.8 to install Minimserver 2 bobzy 10 369 04-Jun-2021, 08:10 AM
Last Post: bobzy
  Problem with installing Snakeoil on Raspberry szczemirek 5 194 03-Jun-2021, 05:30 AM
Last Post: mkysimes
  [SOLVEDSnakeOil OS suddenly refuses to boot. Help needed! koko6969koki 6 1,086 12-May-2021, 11:34 PM
Last Post: koko6969koki
  HQPlayer 4 install stuck, cannot uninstall Snoopy8 3 151 06-May-2021, 09:24 PM
Last Post: agent_kith



Users browsing this thread: 1 Guest(s)
[-]
Sponsor

[-]
Latest Threads
Can snake oil connect to audio station f...
Last Post: Snoopy8
Today 06:47 AM
» Replies: 1
» Views: 6
Best way to run Snakeoil?
Last Post: Bromf
Today 06:09 AM
» Replies: 3
» Views: 18
Amanero usb module on ess9029pro
Last Post: agent_kith
Yesterday 06:05 PM
» Replies: 3
» Views: 36
Add RompR or/and O!MPD
Last Post: Primare11
24-Jul-2021 03:40 PM
» Replies: 2
» Views: 32
New look Forum
Last Post: agent_kith
24-Jul-2021 03:29 PM
» Replies: 1
» Views: 17

[-]
SnakeoilOS Mission Statement

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.


[-]
Random Quotes
Trouble with PCIe NVMe SSD while install...
VVFC's profile VVFC
Dear all, I see a lot a good comments about Snakeoil OS, so I try to install Snakeoil OS in my NUC (Gigabyte GB-BSi5-6200-rev-10). This NUC has Intel I5 620...

>