Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Upgraded LMS ... broken
#1
Hi Folks

     I followed the LMS upgrade instructions on the the server settings page for the web interface.  The one that says:

An updated version of Logitech Media Server is available and ready to install.A new version of Logitech Media Server is available (8.3.0 - 0). Click here for further information.More
 Please execute the following steps to bring your Logitech Media Server installation up to date:
  • Log in to your server machine using your username and password.
  • Run the following command to execute the installer
  • Code:
    sudo dpkg -i /var/lib/squeezeboxserver/cache/updates/logitechmediaserver_8.3.0_amd64.deb

I did this,  then had to update some Perl binaries.  THings seem a little wierd. I'm not seeing any players???     As this is a backup server (my main snake-oil server is OK and seeing all my client players,  I'm just used to being able to switch between servers)  i'm not in that bad of shape,  but did I just kill the LMS instal on this machine?

Thanks

Tim
Reply

#2
I upgraded using the SnakeOil web interface in the System tab, with no issues.  Please try that.
Reply

#3
there is no upgrade to the newest LMS through the snakeoil app.   That said,  the new LMS seemed to have a bug in the Matrial skin. I had rebooted a couple time with no luck,  Finally  when i looked on my android app remote and there I could see my players.  As soon as I connected one, they all showed up in the material web interfac. Issue solved.
Reply

#4
SSH to the snakeoil PC, and run this:
Code:
sudo apt install -f
That should hopefully install any missing packages.

As for material skin not working with the latest LMS. Try these:
  1. Make sure you're running the latest version. Newer LMS might require an update.
  2. Do a CTRL+F5 and make sure you have reloaded everything (Web Apps are stupid this way)
  3. Press F12 and check the console tab, what are the errors?
Snakeoil Operating System - Music, your way!
Reply

#5
The OP's method works for me without needing anything other than a restart. This after upgrading to Ubuntu 22.04.1

[email protected]:~$ sudo dpkg -i /var/lib/squeezeboxserver/cache/updates/logitechmediaserver_8.3.0_amd64.deb
[sudo] password for patricia:
(Reading database ... 101413 files and directories currently installed.)
Preparing to unpack .../logitechmediaserver_8.3.0_amd64.deb ...
Unpacking logitechmediaserver (8.3.0) over (8.2.1~1652959290) ...
Setting up logitechmediaserver (8.3.0) ...
Installing new version of config file /etc/default/logitechmediaserver ...
Installing new version of config file /etc/squeezeboxserver/types.conf ...
invoke-rc.d: policy-rc.d denied execution of restart.
[email protected]:~$ sudo apt install -f
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[-] The following 1 user Likes patricia1066's post:
  • agent_kith
Reply

#6
Is anyone else having problems getting LMS to recognize mounted music in Snakeoil?  I have my NAS mounted - I can see it and browse on the  Snakeoil web app and when I use myMPD it has no problems seeing it.

On LMS server settings under music folders I have /media/music/“nas name” and /media/music/ram.  I can browse to these folders in LMS but they are empty.  I have rescanned multiple times, it comes up empty again with scan completed and zero files.

I updated LMS to 8.3.0 using the directions here -success for update- but no difference in seeing what is mounted on the Snakeoil machine, still comes up empty.

I also use another installation of LMS on another machine- I shut that one down just for trouble shooting -but no difference.

Edit: just saw in another thread that I need to add NFS permissions for LMS on my NAS -but shouldn’t I have been able to what was loaded in RAM on the Snakeoil machine?
Reply

#7
Have you mounted the folders in SO Music Library?  If so, then you should use the same path names in LMS.
Reply

#8
(Yesterday, 06:16 AM)cpcat Wrote: Edit: just saw in another thread that I need to add NFS permissions for LMS on my NAS -but shouldn’t I have been able to what was loaded in RAM on the Snakeoil machine?
That is a likely issue, but not the only one. Usually the NAS would have some form of logs to tell you what the problem is.

What do you mean by your question in bold?
Snakeoil Operating System - Music, your way!
Reply

#9
Snoopy:  yes the library from the NAS is loaded via NFS share on the SO machine - I can browse it
, myMPD recognizes and plays fine.  LMS -when I load via the remote link on the SO machine - doesn’t see it - the folders are there in LMS but empty.  LMS sees and plays fine for loaded music internally on SO machine.  

Agent Kith:  I was referring to the fact that LMS neither sees library loaded from NAS under media/music/mountpoint nor at media/music/ram
-even though I can see it is loaded in ram and browse it under ram on the SO machine.
Reply

#10
Solved it.  I upgraded to FW 1.2.10 then retried to add a CIFS share from my NAS and success.
Now LMS sees it.  Not sure why LMS isn't seeing the NFS share.

Now I will unmount the NFS share and confirm that everything works with both myMPD and LMS with the CIFS share.

Below a screenshot of my shares with NFS and CIFS -I removed my username and password.

   
[-] The following 1 user Likes cpcat's post:
  • Snoopy8
Reply



Bookmarks

Possibly Related Threads…
Thread Author Replies Views Last Post
  SnakeOil STOPPED working after upgraded to 20.04 LTS hkphantomgtr 5 969 21-Oct-2020, 09:46 AM
Last Post: hkphantomgtr



Users browsing this thread:
1 Guest(s)

[-]
Our Sponsors

[-]
Welcome
You have to register before you can post on our site.

Username/Email:


Password:





[-]
Latest Threads
Snakeoil Firmware - 1.2.10 (Gear Isolati...
Last Post: Snoopy8
Today 02:38 PM
» Replies: 12
» Views: 486
Upgraded LMS ... broken
Last Post: cpcat
Today 10:33 AM
» Replies: 10
» Views: 118
Am I missing something in terms of SQ be...
Last Post: hkphantomgtr
Today 12:16 AM
» Replies: 2
» Views: 29
Holo Audio Red
Last Post: rocky
Yesterday 07:18 PM
» Replies: 13
» Views: 260
Noob question: How do I install Snakeoil...
Last Post: uglymusic
Yesterday 06:13 PM
» Replies: 24
» Views: 297
Snakeoil Installer- 1.2.6 (Gear Isolatio...
Last Post: agent_kith
Yesterday 04:50 PM
» Replies: 70
» Views: 3596
LMS scans no music
Last Post: cpcat
Yesterday 06:24 AM
» Replies: 3
» Views: 60
roonbridge 和 roonserver 安装同样错误
Last Post: wxrbbs
31-Jan-2023 06:49 PM
» Replies: 1
» Views: 36
Diretta protocol
Last Post: Evach
30-Jan-2023 05:12 PM
» Replies: 4
» Views: 101
What is your favourite player under Snak...
Last Post: agent_kith
26-Jan-2023 08:25 AM
» Replies: 12
» Views: 1753

[-]
SnakeoilOS Mission Statement

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.


Powered By MyBB, © 2002-2023. Theme © Melroy van den Berg.