Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

Using Snakeoil on a Minnowboard TurboT


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#21
(21-Jun-2018, 01:25 PM) agent_kith Wrote:
(21-Jun-2018, 01:01 PM) Mivera Wrote: It only flashes the message for a split second then goes to the shell or Bios. Too fast to take a picture. It's a very short message. Same message you get if you put any non-bootable drive in. 

UEFI shell? Or Linux shell?

If UEFI, can you go into the BIOS and enable legacy boot? 


Okay I'll try to do a legacy boot. I found this:

"The UEFI firmware has many options to enable different modes of the various subsystems on the board and in the SOC. The defaults are optimized to support loading modern OSs such as Linux and Windows, but there is support for legacy modes or esoteric bespoke configurations that could cause generic OSs looking for vanilla Intel Architecture environments to panic. The defaults are always applied whenever a new firmware is loaded, so that is one simple way to restore known working settings. There are also menu options to restore the factory defaults in the UEFI boot menus."

https://minnowboard.org/tutorials/gettin...leshooting


I looked through everything in the UEFI menu and only way to boot I can find is EFI boot. There's not a whole lot that can be changed for boot options.

After more research I discovered that a custom firmware from a 3rd party needs flashed for legacy boot. I would rather get it going with EFI boot.
 Reply
#22
The 64 bit Snakeoil OS ISO should have a UEFI bootloader. But so far nobody told me if it works or not.

Try and create the UEFI USB stick via this instructions and see if it boots up?
Snakeoil Operating System - Music, your way!
 Reply
#23
Tried that and get the message in the screenshot. Obviously the issue is this Minnowboard firmware is EFI only and the Snakeoil image is for Bios. 


[Image: unnamed.png]
 Reply
#24
Interesting, so it can't see the UEFI partition in the ISO now.. I'd have to check this later after work. Hopefully it's just a bug in my build pipelines.

Stay tuned. Will update you when I can.
Snakeoil Operating System - Music, your way!
 Reply
#25
Rufus..?  FAT32...?    Build using etcher and 'any other' file-system ....

https://etcher.io/

https://minnowboard.org/tutorials/instal...buntu-lts/
https://minnowboard.org/tutorials/best-p...-selection
 1 Normal BIOS initialization When the board is first powered on, the following indications are provided:
  • HDMI: The screen blanks, then a 5-second progress bar appears. Pressing F2 or Delete in this period aborts the normal boot process.
  • Serial port: The screen is cleared, then a 5-second countdown appears. Pressing Esc or Delete in this period aborts the normal boot process.
If a bootable image is found on one of the media, the BIOS attempts to load it. The order the media is probed is configurable, but the factory default is [what is the default on the 0.96 and 0.64 FW?]If no image is found, or no image successfully loads, the BIOS drops into the UEFI shell, with a display showing the media that was detected, and a shell prompt. To access the BIOS GUI menu, type
Code:
exit

and press Enter or Return.If the normal boot process was aborted by pressing one of the abort keys, the BIOS GUI is immediately shown.
[-] The following 1 user Likes Bromf's post:
  • agent_kith
 Reply
#26
(21-Jun-2018, 03:43 PM) Bromf Wrote: Rufus..?  FAT32...?    Build using etcher and 'any other' file-system ....

https://etcher.io/

https://minnowboard.org/tutorials/instal...buntu-lts/
https://minnowboard.org/tutorials/best-p...-selection

Thanks. I know it's defintiely possible to create a UEFI bootable USB stick from normal ISOs. Hopefully you (or somebody) can help me write a good HOWTO on how to get this to work. Thumbs Up

This is in my todo list, but havn't got to look into this yet.
Snakeoil Operating System - Music, your way!
 Reply
#27
The Minnowboard instructions appear to have a keystroke access to bios install as a selection that overides efi....??  see above ...

and this...
The MinnowBoard MAX uses a UEFI system level firmware, and provides both the UEFI shell, and a typical BIOS style menu interface.

from here...https://elinux.org/index.php?title=Minnowboard:MaxBios&oldid=389711#BIOS_menu
 Reply
#28
The 64 bit TurboT with the stock firmware isn't capable of legacy Bios boot. EFI only. Unless you have a 3rd party firmware. I have tried with etcher as well. Same thing. I think when Rufus recognizes it as an EFI bootable image, so will my Minnowboard and it will boot. However I needed to download an older version of Rufus to even get the option to choose UEFI with GPT. The newest doesn't give the option. It auto senses.  So I downloaded 2.17.
 Reply
#29
Interesting....  AK... I wonder if 'mkusb' would be useful here ?  I know it has an option for UEFI boot for making live ubuntu with persistence on usb drives.
I have used it several times for persistence (as that is now removed from the standard Ubuntu live image creator)

I would test it for UEFI but my hardware is all so ancient none has UEFI, lol.
(EDIT just remembered I have an HP thin client somewhere that I think has UEFI boot... I will dig it out this weekend and see if I can test.)

Mivera would have to run from an Ubuntu live distro to run and build as they appear to use windows as their os.

https://help.ubuntu.com/community/mkusb

"the target drive will be able to boot and install in BIOS mode as well as in UEFI mode. "
 sudo add-apt-repository ppa:mkusb/ppa
sudo apt-get update
sudo apt-get install mkusb mkusb-nox usb-pack-efi



T
here is a how to for ubuntu here too...
https://ubuntuforums.org/showthread.php?t=2276498
 Reply
#30
Any progress on an EFI bootable image/
 Reply
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Latest Threads
[-]
Advertising
[-]
Possibly Related Threads…
 

Users browsing this thread: 1 Guest(s)