Upgraded LMS ... broken
Hi Folks

     I followed the LMS upgrade instructions on the the server settings page for the web interface.  The one that says:

An updated version of Logitech Media Server is available and ready to install.A new version of Logitech Media Server is available (8.3.0 - 0). Click here for further information.More
 Please execute the following steps to bring your Logitech Media Server installation up to date:
  • Log in to your server machine using your username and password.
  • Run the following command to execute the installer
  • Code:
    sudo dpkg -i /var/lib/squeezeboxserver/cache/updates/logitechmediaserver_8.3.0_amd64.deb

I did this,  then had to update some Perl binaries.  THings seem a little wierd. I'm not seeing any players???     As this is a backup server (my main snake-oil server is OK and seeing all my client players,  I'm just used to being able to switch between servers)  i'm not in that bad of shape,  but did I just kill the LMS instal on this machine?



I upgraded using the SnakeOil web interface in the System tab, with no issues.  Please try that.

there is no upgrade to the newest LMS through the snakeoil app.   That said,  the new LMS seemed to have a bug in the Matrial skin. I had rebooted a couple time with no luck,  Finally  when i looked on my android app remote and there I could see my players.  As soon as I connected one, they all showed up in the material web interfac. Issue solved.

SSH to the snakeoil PC, and run this:
sudo apt install -f
That should hopefully install any missing packages.

As for material skin not working with the latest LMS. Try these:
  1. Make sure you're running the latest version. Newer LMS might require an update.
  2. Do a CTRL+F5 and make sure you have reloaded everything (Web Apps are stupid this way)
  3. Press F12 and check the console tab, what are the errors?
Snakeoil Operating System - Music, your way!

The OP's method works for me without needing anything other than a restart. This after upgrading to Ubuntu 22.04.1

patricia@t520:~$ sudo dpkg -i /var/lib/squeezeboxserver/cache/updates/logitechmediaserver_8.3.0_amd64.deb
[sudo] password for patricia:
(Reading database ... 101413 files and directories currently installed.)
Preparing to unpack .../logitechmediaserver_8.3.0_amd64.deb ...
Unpacking logitechmediaserver (8.3.0) over (8.2.1~1652959290) ...
Setting up logitechmediaserver (8.3.0) ...
Installing new version of config file /etc/default/logitechmediaserver ...
Installing new version of config file /etc/squeezeboxserver/types.conf ...
invoke-rc.d: policy-rc.d denied execution of restart.
patricia@t520:~$ sudo apt install -f
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
[-] The following 1 user Likes patricia1066's post:
  • agent_kith

Is anyone else having problems getting LMS to recognize mounted music in Snakeoil?  I have my NAS mounted - I can see it and browse on the  Snakeoil web app and when I use myMPD it has no problems seeing it.

On LMS server settings under music folders I have /media/music/“nas name” and /media/music/ram.  I can browse to these folders in LMS but they are empty.  I have rescanned multiple times, it comes up empty again with scan completed and zero files.

I updated LMS to 8.3.0 using the directions here -success for update- but no difference in seeing what is mounted on the Snakeoil machine, still comes up empty.

I also use another installation of LMS on another machine- I shut that one down just for trouble shooting -but no difference.

Edit: just saw in another thread that I need to add NFS permissions for LMS on my NAS -but shouldn’t I have been able to what was loaded in RAM on the Snakeoil machine?

Have you mounted the folders in SO Music Library?  If so, then you should use the same path names in LMS.

(01-Feb-2023, 06:16 AM)cpcat Wrote: Edit: just saw in another thread that I need to add NFS permissions for LMS on my NAS -but shouldn’t I have been able to what was loaded in RAM on the Snakeoil machine?
That is a likely issue, but not the only one. Usually the NAS would have some form of logs to tell you what the problem is.

What do you mean by your question in bold?
Snakeoil Operating System - Music, your way!

Snoopy:  yes the library from the NAS is loaded via NFS share on the SO machine - I can browse it
, myMPD recognizes and plays fine.  LMS -when I load via the remote link on the SO machine - doesn’t see it - the folders are there in LMS but empty.  LMS sees and plays fine for loaded music internally on SO machine.  

Agent Kith:  I was referring to the fact that LMS neither sees library loaded from NAS under media/music/mountpoint nor at media/music/ram
-even though I can see it is loaded in ram and browse it under ram on the SO machine.

Solved it.  I upgraded to FW 1.2.10 then retried to add a CIFS share from my NAS and success.
Now LMS sees it.  Not sure why LMS isn't seeing the NFS share.

Now I will unmount the NFS share and confirm that everything works with both myMPD and LMS with the CIFS share.

Below a screenshot of my shares with NFS and CIFS -I removed my username and password.

[-] The following 1 user Likes cpcat's post:
  • Snoopy8


Possibly Related Threads…
Thread Author Replies Views Last Post
  SnakeOil STOPPED working after upgraded to 20.04 LTS hkphantomgtr 5 1,135 21-Oct-2020, 09:46 AM
Last Post: hkphantomgtr

Users browsing this thread:

Our Sponsors

You have to register before you can post on our site.



Latest Threads
No device audio
Last Post: [email protected]
Today 01:57 AM
» Replies: 4
» Views: 131
Working on new Snakeoil release - 1.3.x ...
Last Post: agent_kith
25-Sep-2023 01:59 PM
» Replies: 12
» Views: 271
Not able to add custom audio output
Last Post: agent_kith
24-Sep-2023 07:43 AM
» Replies: 1
» Views: 49
Activation Code not received
Last Post: sjtuross
20-Sep-2023 02:19 PM
» Replies: 2
» Views: 44
Last Post: ea59
14-Sep-2023 12:33 AM
» Replies: 0
» Views: 39
CamillaDSP for Room Correction
Last Post: hkphantomgtr
09-Sep-2023 02:03 PM
» Replies: 20
» Views: 3303
Snakeoil Firmware - 1.2.6 (Gear Isolatio...
Last Post: hkphantomgtr
08-Sep-2023 01:15 PM
» Replies: 26
» Views: 1455
LMS not running on RPi 3B
Last Post: uglymusic
07-Sep-2023 04:09 PM
» Replies: 1
» Views: 45
Snakeoil Firmware - 1.2.13 (Gear Isolati...
Last Post: agent_kith
06-Sep-2023 07:59 AM
» Replies: 4
» Views: 736
Rpi4+AlloDigiOne sig. Snakeoil os instal...
Last Post: agent_kith
06-Sep-2023 07:36 AM
» Replies: 13
» Views: 613

SnakeoilOS Mission Statement

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Powered By MyBB, © 2002-2023. Theme © Melroy van den Berg.