Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

[split] LMS Trouble in 18.04 Bionic and Blind Testing U7


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
I upgraded to 1.1.7 fw and to Ubuntu 18.04.3 LTS effectively in putty. then updated using the webservice.
Since booting up LMS service has not started.
[email protected]:~$ service logitechmediaserver start
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-units ===
Authentication is required to start 'logitechmediaserver.service'.
Multiple identities can be used for authentication:
1. www-data
2. patricia,,, (patricia)
Choose identity to authenticate as (1-2):
Invalid response `patricia'.
==== AUTHENTICATION CANCELED ===
Failed to start logitechmediaserver.service: Access denied
See system logs and 'systemctl status logitechmediaserver.service' for details.
[email protected]:~$
 Go to solution  Reply
#2
Perhaps I can use this wiki to upload latest LMS to Snakeoil. Any changes required by Snakeoil?

http://wiki.slimdevices.com/index.php/Debian_Package
 Reply
#3
(25-Sep-2019, 05:51 AM) patricia1066 Wrote: Perhaps I can use this wiki to upload latest LMS to Snakeoil. Any changes required by Snakeoil?

http://wiki.slimdevices.com/index.php/Debian_Package

You can update LMS manually, but remeber to run:
Code:
sudo service disable logitechmediaserver


This will disable LMS from auto starting. Deferring the start/stop role to Snakeoil instead. If you select LMS as the music server, Snakeoil will automatically start LMS.

This will conserve your system resources should you want to experiment with another player, e.g. MPD. In this instance, Snakeoil will shutdown LMS and start MPD.

PS: The reason why you can't start LMS in your earlier post is because you didn't use "sudo". Also starting (or restarting) the service manually is unnecessary as it's best to leave this to Snakeoil.
Snakeoil Operating System - Music, your way!
[-] The following 1 user Likes agent_kith's post:
  • patricia1066
 Reply
#4
(25-Sep-2019, 08:42 AM) agent_kith Wrote:
(25-Sep-2019, 05:51 AM) patricia1066 Wrote: Perhaps I can use this wiki to upload latest LMS to Snakeoil. Any changes required by Snakeoil?

http://wiki.slimdevices.com/index.php/Debian_Package

You can update LMS manually, but remeber to run:
Code:
sudo service disable logitechmediaserver


This will disable LMS from auto starting. Deferring the start/stop role to Snakeoil instead. If you select LMS as the music server, Snakeoil will automatically start LMS.

This will conserve your system resources should you want to experiment with another player, e.g. MPD. In this instance, Snakeoil will shutdown LMS and start MPD.

PS: The reason why you can't start LMS in your earlier post is because you didn't use "sudo". Also starting (or restarting) the service manually is unnecessary as it's best to leave this to Snakeoil.


LMS is correctly installed, so I hope I can get it to start by tweaking it. It wont start through Snakeoil at the moment - see the screenshot. The LMS service starts without comment in putty, but fails to open either by producing a LMS link on the Music Player tab of Snakeoil, or by opening on the a browser when I type in the correct IP address. LMS is correctly installed. 
[Image: lms-hangs.jpg]
Code:
[font][font][font][email protected]:~$ sudo apt-cache policy logitechmediaserver
logitechmediaserver:
  Installed: 7.9.0~1475786002
  Candidate: 7.9.0~1475786002
  Version table:
 *** 7.9.0~1475786002 100
        100 /var/lib/dpkg/status
Package: logitechmediaserver
Status: install ok installed[/font][/font][/font]

 Reply
#5
I reinstalled LMS from the nightlies wget and dpkg -i. Its working now, I haven't yet disabled service as the webGUI is working fine. Listening to the Bossa Nova now  Smile

I read elsewhere that others have had problems getting LMS to work when upgrading to Ubuntu 18.04. There was straightforward advice to check systemctl and reinstall when it failed to start, despite startup script appearing to execute.
 
Code:
 
[email protected]:~$ sudo systemctl daemon-reload
[email protected]:~$ sudo systemctl enable logitechmediaserver.service
logitechmediaserver.service is not a native service, redirecting to systemd-sysv                                                                                                                -install.
Executing: /lib/systemd/systemd-sysv-install enable logitechmediaserver
[email protected]:~$ sudo service logitechmediaserver start
[email protected]:~$ sudo systemctl start logitechmediaserver.service
[email protected]:~$ sudo systemctl status logitechmediaserver.servicelogitechmediaserver.service - LSB: Startup script for the Logitech Media Server
   Loaded: loaded (/etc/init.d/logitechmediaserver; generated)
   Active: active (running) since Wed 2019-09-25 14:25:14 BST; 4h 16min ago
     Docs: man:systemd-sysv-generator(8)
   CGroup: /system.slice/logitechmediaserver.service
           ├─5185 sleep 5
           └─8565 /bin/bash /usr/sbin/squeezeboxserver_safe /usr/sbin/squeezeboxserver --prefsdir /var/lib/squeezeboxserver/prefs --logdir /var/log/squeezeboxserver/ --cachedir /var/lib/squeezSep 25 14:25:14 t520 systemd[1]: Starting LSB: Startup script for the Logitech Media Server...
Sep 25 14:25:14 t520 logitechmediaserver[8556]: Making sure that Logitech Media Server is not running first: start-stop-daemon: warning: failed to kill 8304: No such process
Sep 25 14:25:14 t520 logitechmediaserver[8556]: No process in pidfile '/var/run/logitechmediaserver.pid' found running; none killed.
Sep 25 14:25:14 t520 logitechmediaserver[8556]: Starting Logitech Media Server.
Sep 25 14:25:14 t520 systemd[1]: Started LSB: Startup script for the Logitech Media Server. 


Code:
[email protected]:~$ sudo service disable logitechmediaserver
[sudo] password for patricia:
disable: unrecognized service
[email protected]:~$ sudo systemctl enable logitechmediaserver.service
logitechmediaserver.service is not a native service, redirecting to systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable logitechmediaserver

I spoke too soon. I restarted and now LMS wont run either as a Snakeoil service or when I manually put IP:9000 into a browser window. 
Back to where I started yesterday I'm afraid. 
I would like to have LMS, and I will remove MPD via the webGUI. Is there a better version to 
Code:
[color=#000000]logitechmediaserver_7.9.2~1568726655_amd64.deb[/color]

 Reply
#6
Hi Pat,

Gonna split this up into it's own dedicated thread for better SEO. I'm almost certain Bionic is still using systemctl. So you don't have to run "service". To get this working, SSH into your machine, and run:
Code:
sudo systemctl disable logitechmediaserver


Make sure your LMS have all the necessary dependicies by running the following:
Code:
sudo apt install -f


next, reboot the Snakeoil PC.

Now login to the Snakeoil webApp. You should still see LogitechMediaServer as one of the media players. Make sure this option is selected. If you are only using LMS as a server, uncheck the client box. Now hit Save.

Wait for the players to load. And you should see at the top that the LMS is loaded (it'll show you a PID), or errored out (red error text).

If these steps don't work, click on the red error text and let me know what it says.
Snakeoil Operating System - Music, your way!
 Reply
#7
(26-Sep-2019, 07:44 AM) agent_kith Wrote: Hi Pat,

Gonna split this up into it's own dedicated thread for better SEO. I'm almost certain Bionic is still using systemctl. So you don't have to run "service". To get this working, SSH into your machine, and run:
Code:
sudo systemctl disable logitechmediaserver


Make sure your LMS have all the necessary dependicies by running the following:
Code:
sudo apt install -f


next, reboot the Snakeoil PC.

Now login to the Snakeoil webApp. You should still see LogitechMediaServer as one of the media players. Make sure this option is selected. If you are only using LMS as a server, uncheck the client box. Now hit Save.

Wait for the players to load. And you should see at the top that the LMS is loaded (it'll show you a PID), or errored out (red error text).

If these steps don't work, click on the red error text and let me know what it says.

I followed the steps, code and uninstalling squeezelite players and LMS did start up independent of Snakeoil. The Player page has shown "working" symbol after two restarts. Yet LMS is actually playing to a SB3 and a valid LMS link has been provided by the webGUI. No PID though or red error yet. Its still working, It says its waiting for a client although all the squeezelite players have been uninstalled. 

Next step is to reinstall a client player and choose it, I'll update this which you will read in the early hours of a UK day!
By the way, thanks for such quick and on point assistance.
 Reply
#8
I tried with and without the client player; still the spinning wheel every time. This is the LMS log since I started it up this evening.
Code:
[19-09-26 23:29:04.1001] main::init (387) Starting Logitech Media Server (v7.9.2, 1568726655, Tue Sep 17 15:48:36 CEST 2019) perl 5.026001 - x86_64-linux-gnu-thread-multi
2019-09-26 23:31:38 squeezeboxserver_safe stopped.
2019-09-26 23:31:39 squeezeboxserver_safe started.
[19-09-26 23:31:41.8401] main::init (387) Starting Logitech Media Server (v7.9.2, 1568726655, Tue Sep 17 15:48:36 CEST 2019) perl 5.026001 - x86_64-linux-gnu-thread-multi
[19-09-26 23:31:44.5889] Slim::Web::JSONRPC::requestMethod (486) 00:04:20:12:91:e4: request not dispatchable!
2019-09-26 23:31:52 squeezeboxserver_safe stopped.
2019-09-26 23:31:52 squeezeboxserver_safe started.
[19-09-26 23:31:55.4344] main::init (387) Starting Logitech Media Server (v7.9.2, 1568726655, Tue Sep 17 15:48:36 CEST 2019) perl 5.026001 - x86_64-linux-gnu-thread-multi
[19-09-26 23:31:58.5898] Slim::Web::JSONRPC::requestMethod (486) 00:04:20:12:91:e4: request not dispatchable

 Reply
#9
Probably a good idea for me to do a team viewer session with you, so I can remotely log in and see what's going on. Will email you shortly with details.
Snakeoil Operating System - Music, your way!
[-] The following 1 user Likes agent_kith's post:
  • patricia1066
 Reply
#10
Thanks Agent Kith, you set me up with version 1.0 and the file sharing kernel; updating to Ubuntu 18.04 breaks this. Thanks for showing me how easy it is to install a .deb for LMS nightly. Literally drag and drop into the browser window. Follow up with 
Code:
sudo service disable logitechmediaserver

Later I added users to the audio group as advised in the squeezebox Debian article I linked to; changed the workgroup in /etc/samba/smb.conf; 

Its all working well with full audio codecs in place for LMS. If anything else was needed to set it up can you comment here please.
 Reply
 
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Latest Threads
[-]
Advertising
[-]
Possibly Related Threads…
 

Users browsing this thread: 1 Guest(s)