Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login
Poll: Are You Interested In ARMv7 Edition of Snakeoil OS
You do not have permission to vote in this poll.
* You voted for this item.
 Previous 1 6 7 8 9 10 Next   

Any Interest in ARMv7 builds


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#71
(03-Oct-2018, 03:19 PM) Bromf Wrote: Fixed !!!!!!    LIRC is working !!!!  On the rtkernel.... so no need to recompile with modules.....

For some odd reason the rt-kernel does not use /dev/lirc0   but does use /dev/lirc1

Having found that and run the lirc configuration using /dev/lirc1 it all completes and works.. Smile

Nicely done... can you check /etc/udev/, somewhere in there should have two entries for lirc0 and lirc1...

Delete them both, and reboot. the device should now show up as /dev/lirc0 then.
Snakeoil Operating System - Music, your way!
 Reply
#72
looked in /etc/udev/.... contains  hwdb.d  rules.d  udev.conf 
No lirc reference in the last two and the first returns to the prompt when running ls
 Reply
#73
(03-Oct-2018, 04:10 PM) Bromf Wrote: looked in /etc/udev/.... contains  hwdb.d  rules.d  udev.conf 
No lirc reference in the last two and the first returns to the prompt when running ls


It should be inside rules.d

try and do a 
Code:
grep lirc /etc/udev -R

Snakeoil Operating System - Music, your way!
 Reply
#74
[email protected]:~ $ grep lirc /etc/udev -R
[email protected]:~ $ cd /etc/udev/
[email protected]:/etc/udev $ ls
hwdb.d  rules.d  udev.conf
[email protected]:/etc/udev $ cd rules.d
[email protected]:/etc/udev/rules.d $ ls
99-com.rules
[email protected]:/etc/udev/rules.d $ nano 99-com.rules

and the 99-com.rules contains.... (no lirc0 or lirc1)
Code:
SUBSYSTEM=="input", GROUP="input", MODE="0660"
SUBSYSTEM=="i2c-dev", GROUP="i2c", MODE="0660"
SUBSYSTEM=="spidev", GROUP="spi", MODE="0660"
SUBSYSTEM=="bcm2835-gpiomem", GROUP="gpio", MODE="0660"

SUBSYSTEM=="gpio", GROUP="gpio", MODE="0660"
SUBSYSTEM=="gpio*", PROGRAM="/bin/sh -c '\
        chown -R root:gpio /sys/class/gpio && chmod -R 770 /sys/class/gpio;\
        chown -R root:gpio /sys/devices/virtual/gpio && chmod -R 770 /sys/devic$
        chown -R root:gpio /sys$devpath && chmod -R 770 /sys$devpath\
'"

KERNEL=="ttyAMA[01]", PROGRAM="/bin/sh -c '\
        ALIASES=/proc/device-tree/aliases; \
        if cmp -s $ALIASES/uart0 $ALIASES/serial0; then \
                echo 0;\
        elif cmp -s $ALIASES/uart0 $ALIASES/serial1; then \
                echo 1; \
        else \
                exit 1; \
        fi\
'", SYMLINK+="serial%c"

KERNEL=="ttyS0", PROGRAM="/bin/sh -c '\
        ALIASES=/proc/device-tree/aliases; \
        if cmp -s $ALIASES/uart1 $ALIASES/serial0; then \
                echo 0; \
        elif cmp -s $ALIASES/uart1 $ALIASES/serial1; then \
                echo 1; \
        else \
                exit 1; \
        fi \
'", SYMLINK+="serial%c"

 Reply
#75
Hmm. interesting.. Probably leave it be, if it works now, probably not a good idea to break it. :wacky:
Snakeoil Operating System - Music, your way!
 Reply
#76
(03-Oct-2018, 06:32 PM) agent_kith Wrote: Hmm. interesting.. Probably leave it be, if it works now, probably not a good idea to break it. wacky


To which I concur wholeheartedly... LOL
 Reply
#77
Is mpd built with the fifo plugin ?
https://github.com/MusicPlayerDaemon/MPD...Plugin.cxx

I'm trying to get the spectrum analyser running on the Oled display but keep getting this error...
**** 2018-10-04T13:31:23
**** MPD (v20)

Executable: cd /var/www;_NAME="USB Audio" _OUTPUT="hw:1,0" _FORMAT="dop" _OPTIONS=""  /var/www/players/mpd-v20/init /var/www/players/mpd-v20 2>&1;/var/www/players/mpd-v20/start /var/www/players/mpd-v20 2>&1;
exception: Failed to configure output in line 380
exception: nested: No such audio output plugin: fifo
 Reply
#78
(04-Oct-2018, 10:00 AM) Bromf Wrote: Is mpd built with the fifo plugin ?
https://github.com/MusicPlayerDaemon/MPD...Plugin.cxx

I'm trying to get the spectrum analyser running on the Oled display but keep getting this error...
**** 2018-10-04T13:31:23
**** MPD (v20)

Executable: cd /var/www;_NAME="USB Audio" _OUTPUT="hw:1,0" _FORMAT="dop" _OPTIONS=""  /var/www/players/mpd-v20/init /var/www/players/mpd-v20 2>&1;/var/www/players/mpd-v20/start /var/www/players/mpd-v20 2>&1;
exception: Failed to configure output in line 380
exception: nested: No such audio output plugin: fifo

No it's not.. Don't think adding that will affect SQ, will rebuild MPD with FIFO and then you can try again. Can't do this now, but hopefully later tonight when I get home (if not Friday or the weekend)...
Snakeoil Operating System - Music, your way!
[-] The following 1 user Likes agent_kith's post:
  • Bromf
 Reply
#79
Firmware with Mpd and fifo fixed the display output Smile
[-] The following 1 user Likes Bromf's post:
  • agent_kith
 Reply
#80
Trying to copy files from PC to Pi..... samba is set in snakeoil but connection is refused...
Tried every combination I can think of but no joy.
Standard Snakeoil is simply a matter of specifying  smb://<ip address> but that fails on the pi....
 Reply
 Previous 1 6 7 8 9 10 Next   
 
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Latest Threads
[-]
Advertising
[-]
 

Users browsing this thread: 1 Guest(s)