Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

Repository Error


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
In this latest update of LMS 8, the following change was made:
 
  • PR #267 - HTTPS certificates are now validated when LMS acts as a client. HTTPS connections to plugin repositories are no-longer retried over HTTP when they fail. The old insecure behaviour can optionally be re-enabled, although, instead, we recommend working out why HTTPS is broken in your environment and fixing that if possible. 
With this change this error appears in the Plugins section

"https://repos.squeezecommunity.org/extensions.xml - Connect timed out"

Any idea what has to be changes to get rid of this error?

Thank you

ps. Still loving SO, best LMS I've  used.
 Reply
#2
(12-Oct-2020, 11:51 AM) nappyhead Wrote: In this latest update of LMS 8, the following change was made:
 
  • PR #267 - HTTPS certificates are now validated when LMS acts as a client. HTTPS connections to plugin repositories are no-longer retried over HTTP when they fail. The old insecure behaviour can optionally be re-enabled, although, instead, we recommend working out why HTTPS is broken in your environment and fixing that if possible. 
With this change this error appears in the Plugins section

"https://repos.squeezecommunity.org/extensions.xml - Connect timed out"

Any idea what has to be changes to get rid of this error?

Thank you

ps. Still loving SO, best LMS I've  used.


Pls. try uninstall it and then reboot and then reinstall it.   Sometimes it helps.   I encounter and solve similar problem with Minimserver recently.  Good Luck. Smile
 Reply
#3
What version of LMS are you on now? I'm on 7.9.4 and still don't have any issues AFAIK inside the plugins config tab. Can you do a screenshot?
Snakeoil Operating System - Music, your way!
 Reply
#4
(12-Oct-2020, 05:19 PM) agent_kith Wrote: [Image: Snakeoil.jpg]

Change made in version 8 of LMS

free image hostingWhat version of LMS are you on now? I'm on 7.9.4 and still don't have any issues AFAIK inside the plugins config tab. Can you do a screenshot?

 Reply
#5
Don't get the problem here with 7.9.4. The URL (https://repos.squeezecommunity.org/extensions.xml) works fine on my side. Can you run the URL in your web browser and confirm it works? Connection time out suggests network issues, rather than invalid SSL certificates.
Snakeoil Operating System - Music, your way!
 Reply
#6
Manually added the repo using http instead of https. something in the OS is blocking HTTPS
 Reply
#7
Which 8.x version of LMS are you using? I'll download that and try it out to see what's happening.
Snakeoil Operating System - Music, your way!
 Reply
#8
All the repository problems has gone with 18.04.5 Lts for me.
Connect to Snakeoil Os with ssh client and command
do-release-upgrade
[-] The following 1 user Likes merterbalci's post:
  • agent_kith
 Reply
 

Bookmarks
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Latest Threads
[-]
Advertising
[-]
 

Users browsing this thread: 1 Guest(s)