[SOLVED] upmpdcli not working on fresh install of 20.04/1.2.0
#1
Upmpdcli installs ok.  But cannot see it as a UPnP player in BubbleUPnP Android app, nor can it be seen as a player in LMS with UPnP Bridge enabled. Also not working with MinimServer.  Not working in fresh install of 20.04/1.2.0, but was running in previous instance of 20.04/1.2 upgraded incrementally since Alpha2.

I tried a fresh install manually, including getting repository key but still no good
https://www.lesbonscomptes.com/upmpdcli/...tml#ubuntu
 Go to solution Reply

#2
Can you setup a MPD player first, and then change to upmpdcli and see if that works?

I've been meaning to fix this quirk - in 1.2.1 (or later) where my intention is to re-work how player selection works.
Snakeoil Operating System - Music, your way!
Reply

#3
(13-May-2021, 04:03 PM)agent_kith Wrote: Can you setup a MPD player first, and then change to upmpdcli and see if that works?

I've been meaning to fix this quirk - in 1.2.1 (or later) where my intention is to re-work how player selection works.

My Bad! Blush   I think I made the same mistake previously!  I uninstalled Mpd 0.21.25 which caused upmpdcli to stop working.  Fixed it by re-installing Mpd 0.21.25.
Reply

#4
I can't even get upmpdcli to install on pi4 or pi3 with a fresh install. Threw the 1.2 firmware over an old 1.1.7 install, which is the last version I got to work, and it won't even start as server or client Sad  

When I revert back to 1.1.7 everthing is fine.
Reply

#5
If i understand properly, i should be able to install upmpdcli and run mconnect to control playback for mpd? For now i am using it via LMS, with upmdpcli as a player. But i was keen to try some of the funky player apps for ipad.

So far this is not working in 1.2.1 for a couple of obvious reason and some not so.

the key servers in the install.sh script are deprecated
repos are set for stretch, but if you're using buster...
even after manually setting up you still get. Unable to locate package upmpdcli-tidal. I think this app is missing/no longer available?

I have upmpdcli running, checked in the gui, but cannot connect.

Is this a simplish fix? I am happy to test or make manual changes if it helps. Should we be using something other than buster on PI? Here some obvious changes to the install.sh hope it helps.

  gpg --keyserver keyserver.ubuntu.com --recv-key F8E3347256922A8AE767605B7808CE96D38B9201
  gpg --export '7808CE96D38B9201' | sudo apt-key add -

  echo "Creating upmpdcli repo"
  echo deb http://www.lesbonscomptes.com/upmpdcli/d.../raspbian/ buster main > ${APT_SRC}
  echo deb-src http://www.lesbonscomptes.com/upmpdcli/d.../raspbian/ buster main >> ${APT_SRC}
Reply

#6
(11-Aug-2021, 07:28 PM)Jimmy99 Wrote: If i understand properly, i should be able to install upmpdcli and run mconnect to control playback for mpd? For now i am using it via LMS, with upmdpcli as a player. But i was keen to try some of the funky player apps for ipad.
There's still some issues with the scripts at the moment, it's still setup to run mpd v21 and not the later mpd v22.

Also, to get this working, you have to select MPD-v21 in the player first, configure an audio device, hit save. Once that is done, switch to upmpdcli and everything will start working. This is something i hope to fix in the next few releases (hopefully the next one with the new GUI if I can make it out).
Snakeoil Operating System - Music, your way!
[-] The following 2 users Like agent_kith's post:
  • patricia1066, Jimmy99
Reply



Bookmarks

Possibly Related Threads…
Thread Author Replies Views Last Post
  Fail to install myMPD sjtuross 4 79 18-Feb-2024, 03:10 PM
Last Post: sjtuross
  [SOLVEDLMS not working with Bookworm Snoopy8 12 240 11-Jan-2024, 05:58 PM
Last Post: Snoopy8
  [SOLVEDCPUset not working in Ubuntu 22.04 Snoopy8 17 1,827 12-Dec-2023, 07:02 PM
Last Post: uglymusic
  upmpdcli mpd and LMS -- set up help! pathetic 13 1,615 23-Nov-2023, 06:32 PM
Last Post: patricia1066
  Install not working Pi2Design Mercury V2 Snoopy8 1 272 01-Aug-2023, 10:03 AM
Last Post: agent_kith



Users browsing this thread:
2 Guest(s)

[-]
Our Sponsors

[-]
Welcome
You have to register before you can post on our site.

Username/Email:


Password:





[-]
Latest Threads
Fail to install myMPD
Last Post: sjtuross
18-Feb-2024 03:10 PM
» Replies: 4
» Views: 79
LMS Upgrade ?
Last Post: uglymusic
18-Feb-2024 05:25 AM
» Replies: 6
» Views: 77
More Problems with Squeezelite in 1.3
Last Post: Coacharnold
17-Feb-2024 09:47 PM
» Replies: 2
» Views: 25
Announcing Snakeoil Measurements 1.3.0
Last Post: Snoopy8
17-Feb-2024 11:29 AM
» Replies: 90
» Views: 2964
Snakeoil Music server & Snakeoil its own...
Last Post: Snoopy8
17-Feb-2024 11:20 AM
» Replies: 8
» Views: 279
RoonBridge (64 bit only)
Last Post: scrarfussi
15-Feb-2024 08:26 PM
» Replies: 3
» Views: 4025
How to upgrade to low latency kernel on ...
Last Post: uglymusic
14-Feb-2024 03:18 PM
» Replies: 11
» Views: 203
Problems with Squeezlite in 1.3
Last Post: Coacharnold
14-Feb-2024 03:20 AM
» Replies: 7
» Views: 140
Install RoonLab's RoonBridge
Last Post: scrarfussi
04-Feb-2024 02:24 AM
» Replies: 2
» Views: 5461
ZimaBoard 2x NIC, 2x SATA, 2x USB, 1x PC...
Last Post: hkphantomgtr
21-Jan-2024 06:26 PM
» Replies: 11
» Views: 507

[-]
SnakeoilOS Mission Statement

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.


Powered By MyBB, © 2002-2024. Theme © Melroy van den Berg.