Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login
1 2 3 4 5 ... 9 Next   

Next Generation Snakeoil Early Preview


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
Here's the preview ISO of the next version of SnakeoilOS. Any bugs/issues please report in this thread. I'd try and fix 'em as soon as I can. For those who have activation codes, they'd still work with this and future releases. People without code, sign up to the forum and PM me for one (You'd get one for F-R-E-E). Request your activation code before the official 1.0.0 final is out. Once 1.0.0 is officially released the only way to get a code is by donating to the SnakeoilOS project.

Edit: Forgot to mention - ignore the sound quality aspect for now and focus on the web-app and overall use. Once the documentations is updated to the latest edition I'd work on the audio.

BETA FIRMWARE UPDATES
Go into System, drag the downloaded file into the install box to update your firmware.

.fw   snakeoil-0.8.3-i686.fw (Size: 12.14 MB / Downloads: 0)
.fw   snakeoil-0.8.3-x86_64.fw (Size: 12.2 MB / Downloads: 13)
---
.fw   snakeoil-0.8.5-i686.fw (Size: 12.25 MB / Downloads: 0)
.fw   snakeoil-0.8.5-x86_64.fw (Size: 12.23 MB / Downloads: 4) For the 5 people who are using 0.8.4 on 64bit OS now, please refer to this post to fix the update bug before updating. Everybody else should be able to update straight to 0.8.5 without issues.
---
.fw   snakeoil-0.8.6-i686.fw (Size: 12.2 MB / Downloads: 0)
.fw   snakeoil-0.8.6-x86_64.fw (Size: 12.23 MB / Downloads: 8)
---
.fw   snakeoil-0.8.7-i686.fw (Size: 20.37 MB / Downloads: 1)
.fw   snakeoil-0.8.7-x86_64.fw (Size: 20.43 MB / Downloads: 6)

Known Beta Issues
Refer here for list of known (and resolved) issues: Link
Snakeoil Operating System - Music, your way!
[-] The following 4 users Like agent_kith's post:
  • polarlight, Bromf, sips, m@jor
 Reply
#2
No sound. Sad
DAC with Amanero USB-receiver
Sorry for my English
[GA-H170M-D3H + Skylake G4400 + SOtM tX-USB] -> L.K.S. Audio MH-DA003 USB Upgrade Edition -> Audio Note P2SE ->Tannoy D500

 
 Reply
#3
No sound. Sad
Built-in sound card.
What do you mean Client disabled? Maybe this is my problem?

[Image: 993jpg_9057290_26358741.jpg]
 Reply
#4
Network mount is gone after restart. After re adding LMS database still there. 
None of MPD servers(players) work.
Internal music folder synchronised with added NAS mount.
Qualcomm® Atheros® AR8171 network adapter not work.

LMS+Squeezelite 1.8 works fine and sounds good already on XMOS.
 Reply
#5
(30-May-2017, 09:46 PM) m@jor Wrote: No sound. Sad
DAC with Amanero USB-receiver

(30-May-2017, 11:47 PM) polarlight Wrote: No sound. Sad
Built-in sound card.

My bad for that. [Image: oh.gif] The volume is muted and turned all the way down by default. SSH into the computer, and run the following to turn it on.

Also, what browser, device are you running on? The fonts and buttons seem a bit out of whack.
 
Code:
amixer set Master 100%
amixer set Master unmute

 
(30-May-2017, 11:47 PM) polarlight Wrote: What do you mean Client disabled? Maybe this is my problem?

MPD (server) don't require an "additional software" (client) to run because it is self contained. I'd update the manual with these new terminology once the i686 ISO is released.
Snakeoil Operating System - Music, your way!
 Reply
#6
(31-May-2017, 01:46 AM) sips Wrote: Network mount is gone after restart. After re adding LMS database still there. 

That's a bug.. Big Grin My bad for that. Will try and test that and fix it in the next firmware release.

(31-May-2017, 01:46 AM) sips Wrote: None of MPD servers(players) work.

MPD disables software volume mixer by default. That will be addressed in the next release.

(31-May-2017, 01:46 AM) sips Wrote: Internal music folder synchronised with added NAS mount.

What do you mean?

(31-May-2017, 01:46 AM) sips Wrote: Qualcomm® Atheros® AR8171 network adapter not work.

Thanks for that. I'd support that in the stock kernel in the next ISO release.

(31-May-2017, 01:46 AM) sips Wrote: LMS+Squeezelite 1.8 works fine and sounds good already on XMOS.

Thumbs Up

Keep the bug report coming guys. And sorry to have you guys download/install/reinstall. The more people who are testing this, the more polished the final release will be. And as mentioned previously, PM me if you don't already have an activation code. Test and run everything you can and let me know of any problems (or confusion, e.g. the "client" reference).
Snakeoil Operating System - Music, your way!
 Reply
#7
Quote:sips Wrote: Internal music folder synchronised with added NAS mount.
What do you mean?

The snakeoil system music folder, if I open it from other pc show same as my mounted nas folder. 2 folders in mirror. snakeoil\music=nas\shared folder. Maybe it is normal, not a bug.
 Reply
#8
(31-May-2017, 12:10 PM) sips Wrote: The snakeoil system music folder, if I open it from other pc show same as my mounted nas folder. 2 folders in mirror. snakeoil\music=nas\shared folder. Maybe it is normal, not a bug.

can you take a picture? Thanks.
Snakeoil Operating System - Music, your way!
 Reply
#9
(31-May-2017, 08:03 AM) agent_kith Wrote:  
Code:
amixer set Master 100%
amixer set Master unmute



It does not help:

major@slakeoil:~$ sudo amixer set Master 100%
amixer: Unable to find simple control 'Master',0

major@slakeoil:~$ sudo amixer set Master unmute
amixer: Unable to find simple control 'Master',0


Probably something is wrong with the setup of the audio device


[Image: 278Cba94.jpg]

image upload

MPD v20 mpd.conf :
audio_output {
   type "alsa"
   name "Combo384 Amanero"
   device "hw:0,0"
   buffer_time "40000"
   period_time "10000"
     mixer_type      "none"
   auto_format  "no"
   auto_channels "no"
   replay_gain_handler "none"
   use_mmap "yes"
   dsd_usb "yes"
}

And one more bug. MPD (dsd-rt) mpd.conf:
audio_output {
   type "alsa"
   name "Combo384 Amanero"
   device "hw:,"
   buffer_time "40000"
   period_time "10000"
   auto_format  "no"
   auto_channels "no"
     mixer_type      "none"
   replay_gain_handler "none"
   use_mmap "yes"
   dsd_usb "yes"
}
Sorry for my English
[GA-H170M-D3H + Skylake G4400 + SOtM tX-USB] -> L.K.S. Audio MH-DA003 USB Upgrade Edition -> Audio Note P2SE ->Tannoy D500

 
[-] The following 1 user Likes m@jor's post:
  • agent_kith
 Reply
#10
(31-May-2017, 02:48 PM) m@jor Wrote: It does not help:

The standard name should be "Master". But only if people follow the convention. SSH into the machine, and run 
Code:
alsamixer


[Image: NoAudio.png]

For the relevant outputs, set all the volumes to max (Arrow up all the way). Then press "M" so that "MM" reads 00 (unmute). The audio should work then.

Edit: Nice find on the MPD-RT bug.. I'd look into that later today or tomorrow when I can. A bit overwheld @ work righ tnow. Confused Confused
Snakeoil Operating System - Music, your way!
 Reply
1 2 3 4 5 ... 9 Next   
 
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Latest Threads
[-]
Advertising
[-]
Possibly Related Threads...
 

Users browsing this thread: 1 Guest(s)