Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

CIFS mount problem


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#1
As I am new here first I wish a lot of joy to all Snakeoil music lovers.
But, I have a problem with mounting shared drives which reside on Win 7 computer.
I have another box with Volumio where I need to enter vers=2.1 to be able to access the shared folders. In Snakeoil when I enter vers parameter either from GUI or when I try to mount shared folders from the terminal response is 'mount error(22).Invalid argument'.
Even I got the error, folder is created in /media/music but is empty. Shared folders are password protected.
If I try to connect without username/password when clicking on Save button, nothing happens but in the terminal is displayed the message:

Password entry required for 'Password for [email protected]//192.168.1.25/Muzika:' (PID 4069).
Please enter a password with the systemd-tty-ask-password-agent tool!

If I try vers=1.0 there is no complaint about the invalid argument but share failed with error 'mount error(121): Remote I/O error'.

Is there any way to enable vers=2.1?
 Go to solution  Reply
#2
(23-Feb-2019, 06:41 AM) nas963 Wrote: As I am new here first I wish a lot of joy to all Snakeoil music lovers.
But, I have a problem with mounting shared drives which reside on Win 7 computer.
I have another box with Volumio where I need to enter vers=2.1 to be able to access the shared folders. In Snakeoil when I enter vers parameter either from GUI or when I try to mount shared folders from the terminal response is 'mount error(22).Invalid argument'.
Even I got the error, folder is created in /media/music but is empty. Shared folders are password protected.
If I try to connect without username/password when clicking on Save button, nothing happens but in the terminal is displayed the message:

Password entry required for 'Password for [email protected]//192.168.1.25/Muzika:' (PID 4069).
Please enter a password with the systemd-tty-ask-password-agent tool!

If I try vers=1.0 there is no complaint about the invalid argument but share failed with error 'mount error(121): Remote I/O error'.

Is there any way to enable vers=2.1?

I hit this issue recently as well - when FreeNAS deprecate SMBv1. For my case I had to reenable v1 in the NAS to get things to work.

Now that you posted about this, I investigated deeper, and founod out the reason why:
[Image: oJWqINn.png]
The Snakeoil kernel only supports SMBv1!! [Image: bad_atmosphere.gif]

SMBv1 as you know is no longer secure and Microsoft and other NAS makers are slowly phasing this out. I'd rebuild a new kernel with SMBv2/v3 support. You will find this in the kernels section soon. You Windows share would work once you upgrade to this kernel.

There must be a reason why I chose to use SMBv1 only - This has to be AQ related. But AFAICT, I didn't document this, so could also be an oversight. We'd see.
Snakeoil Operating System - Music, your way!
 Reply
#3
Go here and download the filesystems upgrade kernel. Reboot and try to mount the Windows share again, it should work.

Edit: Should work coz I havn't test this myself yet :shy:. I'm going out soon so unfortunately has run out of time.
Snakeoil Operating System - Music, your way!
 Reply
#4
Yes... hoping this is available in the Pi port of Snakeoil as I still can't access Samba shares there....
 Reply
#5
(23-Feb-2019, 09:21 AM) agent_kith Wrote: Go here and download the filesystems upgrade kernel. Reboot and try to mount the Windows share again, it should work.

Edit: Should work coz I havn't test this myself yet Shy. I'm going out soon so unfortunately has run out of time.


In meantime, I forced my Win 7 server to use SMB1 and was able to mount Windows share, but like you, sad SMB1 is not recommended to use because of security reasons.

If somebody needs to enable SMB1 command from PowerShell is:

Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB1 -Type DWORD -Value 1 –Force

to disable SMB1 command is:

Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB1 -Type DWORD -Value 0 –Force
 
I try to install the upgraded kernel, but installation failed with the last two lines:

/cow format specified
stdin: Not a typewriter 
as aufs and not support found
 Reply
#6
(23-Feb-2019, 07:20 PM) nas963 Wrote: I try to install the upgraded kernel, but installation failed with the last two lines:

/cow format specified
stdin: Not a typewriter 
as aufs and not support found 

That's an interesting one. Are you still using Snakeoil OS in liveCD mode, or have you already installed this on a SSD/HDD/USB?
Snakeoil Operating System - Music, your way!
 Reply
#7
(24-Feb-2019, 07:15 PM) agent_kith Wrote:
(23-Feb-2019, 07:20 PM) nas963 Wrote: I try to install the upgraded kernel, but installation failed with the last two lines:

/cow format specified
stdin: Not a typewriter 
as aufs and not support found

That's an interesting one. Are you still using Snakeoil OS in liveCD mode, or have you already installed this on a SSD/HDD/USB? 


I'm unable to install Snakeoil with new vmlinuz. I replaced the original vmlinuz with the new one on my USB stick and try to install it. Installation hangs with last two lines. When I return to the original vmlinuz installation passed normally.
 Reply
#8
(24-Feb-2019, 08:28 PM) nas963 Wrote: I'm unable to install Snakeoil with new vmlinuz. I replaced the original vmlinuz with the new one on my USB stick and try to install it. Installation hangs with last two lines. When I return to the original vmlinuz installation passed normally. 

You need to install the Snakeoil with an install kernel (this is why it requires aufs, for cow - copy on write). Once installed, Snakeoil will be running on a fully fledged file system (EXT4), that is when you use the upgrade kernels (no longer require aufs).

So to install, use the install kernels, once that is done, use the upgrade kernels.

Hope this make sense Confused ?
Snakeoil Operating System - Music, your way!
 Reply
#9
(24-Feb-2019, 08:37 PM) agent_kith Wrote:
(24-Feb-2019, 08:28 PM) nas963 Wrote: I'm unable to install Snakeoil with new vmlinuz. I replaced the original vmlinuz with the new one on my USB stick and try to install it. Installation hangs with last two lines. When I return to the original vmlinuz installation passed normally. 

You need to install the Snakeoil with an install kernel (this is why it requires aufs, for cow - copy on write). Once installed, Snakeoil will be running on a fully fledged file system (EXT4), that is when you use the upgrade kernels (no longer require aufs).

So to install, use the install kernels, once that is done, use the upgrade kernels.

Hope this make sense Confused


My mistake. I follow instructions 'How to modify Snakeoil LiveUSB'.
Now I install the new kernel, disable SMB1 on my Win7 and have access to shared folders without any problem. 
Thanks.
[-] The following 1 user Likes nas963's post:
  • agent_kith
 Reply
#10
(24-Feb-2019, 09:00 PM) nas963 Wrote: My mistake. I follow instructions 'How to modify Snakeoil LiveUSB'.
Now I install the new kernel, disable SMB1 on my Win7 and have access to shared folders without any problem. 
Thanks. 

No problem. It's understandable, coz the way the kernels work are pretty confusing. Hopefully I can find ways to improve on that in the future.
Snakeoil Operating System - Music, your way!
 Reply
 
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Advertising
[-]
Possibly Related Threads...
 

Users browsing this thread: 1 Guest(s)