Help  Search  Portal
 Portal  Search
Hello There, Guest!  Register  Login

Snakeoil Firmware - 1.1.10 (Blind Testing Update 10)


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
 
#21
(01-Oct-2020, 06:54 PM) Snoopy8 Wrote:
(29-Sep-2020, 10:04 AM) hkphantomgtr Wrote: Look, may I know that, can I choose between minimserver 0.8.5.2 and 2.0 in this Update 10? 

I think 0.8 will be removed soon. The license terms prevent it from being hosted elsewhere. If you want to use 0.8, download it now and use Putty to load it manually.

Please note that you are using 0.8, it can continue to be used under the license terms. It will of course have no updates.


Thanks! Actually I worry about the bugs and stability for any major release must more rather than cost (if that's reasonable).
[-] The following 1 user Likes hkphantomgtr's post:
  • Snoopy8
 Reply
#22
(01-Oct-2020, 07:57 PM) hkphantomgtr Wrote: Thanks! Actually I worry about the bugs and stability for any major release must more rather than cost (if that's reasonable).

Yes, it is a major release, but MinimServer 2.0 was the last platform to move from 0.8. So, maybe it is more stable? The other thing is the developer is responsive on the forum and more than likely to quickly to fix any bugs.
[-] The following 1 user Likes Snoopy8's post:
  • hkphantomgtr
 Reply
#23
I'm rather new to snakeoil, so apologies in advance if I ask dummy questions....
I installed "snakeoil-1.1.10-armv7l.fw" on top of "snakeoil-armv7l-1.1.0.img" on a raspberry 3.
Apparently all went well

[Image: 07-firmaware-1-1-10-installed.png]

but after the update I get an erron when I try to start squeezelite (any flavor of it).

Is tehere anything I can do to debug the issue?

Thanks for any help
 Reply
#24
Hi Kith, update well gone on my Ubuntu 16, another great job !

Snakeoil OS always The Best for my audiophile addiction !!! 

Gigi
[-] The following 1 user Likes Gigipack's post:
  • hkphantomgtr
 Reply
#25
(08-Oct-2020, 04:24 AM) franz159 Wrote: I'm rather new to snakeoil, so apologies in advance if I ask dummy questions....
I installed "snakeoil-1.1.10-armv7l.fw" on top of "snakeoil-armv7l-1.1.0.img" on a raspberry 3.
Apparently all went well

[Image: 07-firmaware-1-1-10-installed.png]

but after the update I get an erron when I try to start squeezelite (any flavor of it).

Is tehere anything I can do to debug the issue?

Thanks for any help


I notice in the web interface the client PID changes continuously, as if the process fails starting and it restarted automatically, but failing again and so on....


(08-Oct-2020, 03:20 PM) franz159 Wrote:
(08-Oct-2020, 04:24 AM) franz159 Wrote: I'm rather new to snakeoil, so apologies in advance if I ask dummy questions....
I installed "snakeoil-1.1.10-armv7l.fw" on top of "snakeoil-armv7l-1.1.0.img" on a raspberry 3.
Apparently all went well

[Image: 07-firmaware-1-1-10-installed.png]

but after the update I get an erron when I try to start squeezelite (any flavor of it).

Is tehere anything I can do to debug the issue?

Thanks for any help


I notice in the web interface the client PID changes continuously, as if the process fails starting and it restarted automatically, but failing again and so on....


And I also noticed a bunch of new stuff in the players folders:
 
Code:
 
[b][email protected][/b]:[b]/var/www/players $[/b] ls -l
total 68
drwxr-xr-x 2 www-data www-data 4096 Oct  8 06:56 [b]NAA[/b]
drwxr-xr-x 2 www-data www-data 4096 Oct  8 06:56 [b]RoonBridge[/b]
drwxr-xr-x 2 www-data www-data 4096 Oct  8 07:07 [b]Squeezelite-R2[/b]
drwxr-xr-x 2 www-data www-data 4096 Oct  8 06:56 [b]Squeezelite-ralph-irving-git[/b]
drwxr-xr-x 2 www-data www-data 4096 Oct  8 06:56 [b]Squeezelite-v1.6.4-test[/b]
drwxr-xr-x 2 www-data www-data 4096 Oct  8 06:56 [b]Squeezelite-v1.8[/b]
drwxr-xr-x 2 www-data www-data 4096 Oct  8 06:56 [b]amarok[/b]
drwxr-xr-x 2 www-data www-data 4096 Oct  8 06:56 [b]clementine[/b]
drwxr-xr-x 2 www-data www-data 4096 Oct  8 06:56 [b]lms[/b]
drwxr-xr-x 2 www-data www-data 4096 Aug 26  2018 [b]mpd-dsd-rt[/b]
drwxr-xr-x 2 www-data www-data 4096 Aug 26  2018 [b]mpd-v17[/b]
drwxr-xr-x 2 www-data www-data 4096 Aug 26  2018 [b]mpd-v19[/b]
drwxr-xr-x 2 www-data www-data 4096 Aug 26  2018 [b]mpd-v20[/b]
drwxr-xr-x 2 www-data www-data 4096 Oct  8 06:56 [b]mpd-v21[/b]
drwxr-xr-x 2 www-data www-data 4096 Oct  8 06:56 [b]qmmp[/b]
drwxr-xr-x 2 www-data www-data 4096 Oct  8 06:56 [b]upmpdcli[/b]
drwxr-xr-x 2 www-data www-data 4096 Oct  8 06:56 [b]xmms[/b]
[b][email protected][/b]:[b]/var/www/players $[/b] 

 but nothing new in the interface, for example, to choose mpd-v21.

Also, the choice of server and client modules should be decoupled IMO.
For example, if I have a LMS running already in my LAN (as I have indeed) I should be able to select Squeezelite client without needing to activate LMS Server.

Instead when you select MPD as your server component:
  •  upmpdcli does not seem to be starting properly.
  •  the interface shows a broken link to myMPD on port 8080.

[Image: 08-my-MPDLink.png]

Attached Files

Image(s)
   

 Reply
#26
(08-Oct-2020, 03:20 PM) franz159 Wrote: I'm rather new to snakeoil, so apologies in advance if I ask dummy questions....

There's no such thing as dummy questions. I do encourage people to ask questions as much as possible... It's how I improve Snakeoil.

(08-Oct-2020, 03:20 PM) franz159 Wrote: but after the update I get an erron when I try to start squeezelite (any flavor of it).

Is tehere anything I can do to debug the issue?

Thanks for any help

Generate a diagnostic file and send it over to me to have a look.. It could be a library dependency issue as I've built everything on buster now (Raspberry Pi 4).

(08-Oct-2020, 03:20 PM) franz159 Wrote: I notice in the web interface the client PID changes continuously, as if the process fails starting and it restarted automatically, but failing again and so on....

Yes. That is why it's doing that.

(08-Oct-2020, 03:20 PM) franz159 Wrote: And I also noticed a bunch of new stuff in the players folders:

 but nothing new in the interface, for example, to choose mpd-v21.

mpd-v21 will have the latest version of MPD 0.21.x at the time of the firmware. The name is actually embedded inside the config file in that folder.

This gives you the option of installing a specific version of MPD (it will be in another folder), and the default MPD from the firware will not overwrite your custom installed MPD.

(08-Oct-2020, 03:20 PM) franz159 Wrote: Also, the choice of server and client modules should be decoupled IMO.
For example, if I have a LMS running already in my LAN (as I have indeed) I should be able to select Squeezelite client without needing to activate LMS Server.

It kind of us. You just uncheck the "Start Server" checkbox and only the clients will show up... For example I used to run a 2 PC setup, 1 running server, and the other running client.. See here. I hope I havn't broken this part of the WebApp since it has been a while since I last tested this...

(08-Oct-2020, 03:20 PM) franz159 Wrote: Instead when you select MPD as your server component:
  •  upmpdcli does not seem to be starting properly.
  •  the interface shows a broken link to myMPD on port 8080.

Hmm. Hopefully I can check this later this weekend. Do you have a RPi4? If not, I may need to dig out my old pi 3 and start a new build platform for the 3 .
Snakeoil Operating System - Music, your way!
 Reply

Bookmarks
SnakeoilOS Mission
[-]

Our mission is to create a free to use computer OS that is easy to install, intuitive to operate and play music that will connect and engage with you emotionally.

SnakeoilOS gives you the freedom to spend more time on listening, enjoying and exploring music. Wasting time on computers is now a thing of the past! Everything is constantly evolving/improving. Please check back often for updates.

If you like this project, do show your support with a small token donation. All donations collected will be used to run this website, and for purchasing new equipment for the project.

Latest Threads
[-]
Advertising
[-]
Possibly Related Threads…
 

Users browsing this thread: 1 Guest(s)